summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSefa Eyeoglu2020-10-31 00:13:15 +0100
committerSefa Eyeoglu2020-10-31 00:13:15 +0100
commit3788e1b66f099843d59c06ed28a62152c184b28a (patch)
tree8285316dc85d4e0c8466f842cf108c43917f9b56
parent0cbcc8bed316b16a8c8af40d75d61f32eac4ba06 (diff)
downloadaur-3788e1b66f099843d59c06ed28a62152c184b28a.tar.gz
upgpkg: gamescope-git 3.7.r11.gcd31090-1
Update to support new submodule handling
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
-rw-r--r--use-system-libs.patch50
3 files changed, 7 insertions, 61 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4c74dc59d291..6ce96d153f49 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gamescope-git
pkgdesc = Micro-compositor formerly known as steamcompmgr
- pkgver = 3.6.9.r21.g5644232
+ pkgver = 3.7.r11.gcd31090
pkgrel = 1
url = https://github.com/Plagman/gamescope
arch = x86_64
@@ -22,9 +22,7 @@ pkgbase = gamescope-git
conflicts = gamescope
conflicts = steamcompmgr
source = git+https://github.com/Plagman/gamescope.git
- source = use-system-libs.patch
sha512sums = SKIP
- sha512sums = a36d6bef5ea19a0754ab82df5bc2c5f64c23321fde7be33073953dad76eb8c0af64ae1b5723f4e778a403c6bf75d4df27a524899de3b412d2bacd1cd4052e86a
pkgname = gamescope-git
diff --git a/PKGBUILD b/PKGBUILD
index 224088089c15..c5b46791ea78 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=gamescope
pkgname=${_pkgname}-git
-pkgver=3.6.9.r21.g5644232
+pkgver=3.7.r11.gcd31090
pkgrel=1
pkgdesc="Micro-compositor formerly known as steamcompmgr"
arch=(x86_64)
@@ -12,10 +12,8 @@ depends=("wlroots-git" "sdl2" "libxcomposite" "vulkan-icd-loader" "libxtst" "lib
makedepends=("git" "meson" "ninja" "patch" "vulkan-headers" "glslang")
provides=($_pkgname "steamcompmgr")
conflicts=($_pkgname "steamcompmgr")
-source=("git+https://github.com/Plagman/gamescope.git"
- "use-system-libs.patch")
-sha512sums=('SKIP'
- 'a36d6bef5ea19a0754ab82df5bc2c5f64c23321fde7be33073953dad76eb8c0af64ae1b5723f4e778a403c6bf75d4df27a524899de3b412d2bacd1cd4052e86a')
+source=("git+https://github.com/Plagman/gamescope.git")
+sha512sums=('SKIP')
pkgver() {
@@ -25,14 +23,14 @@ pkgver() {
}
prepare() {
- cd "$srcdir/$_pkgname"
- patch -p1 < "../use-system-libs.patch"
+ rm -rf "$srcdir/$_pkgname/subprojects/libliftoff"
+ rm -rf "$srcdir/$_pkgname/subprojects/wlroots"
}
build() {
- meson --prefix /usr --buildtype=release "$srcdir/$_pkgname" build
+ meson setup --prefix /usr --buildtype=release --wrap-mode=nodownload "$srcdir/$_pkgname" build
ninja -C build
}
diff --git a/use-system-libs.patch b/use-system-libs.patch
deleted file mode 100644
index c1c1e23ba62a..000000000000
--- a/use-system-libs.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-From 4f8f8c2d12a03cddc3ade2ceba13525e086d929d Mon Sep 17 00:00:00 2001
-From: Sefa Eyeoglu <contact@scrumplex.net>
-Date: Fri, 11 Sep 2020 23:48:34 +0200
-Subject: [PATCH] packaging/archlinux: use system libliftoff and wlroots
-
----
- meson.build | 13 ++++---------
- 1 file changed, 4 insertions(+), 9 deletions(-)
-
-diff --git a/meson.build b/meson.build
-index d4fadab..23de301 100644
---- a/meson.build
-+++ b/meson.build
-@@ -45,9 +45,8 @@ thread_dep = dependency('threads')
- cap_dep = cc.find_library('cap')
- sdl_dep = dependency('SDL2')
-
--wlroots_proj = subproject('wlroots', default_options:
-- ['default_library=static', 'examples=false'])
--wlroots_static_dep = wlroots_proj.get_variable('wlroots')
-+liftoff = dependency('liftoff')
-+wlroots = dependency('wlroots')
-
- shadercompiler = find_program('glslangValidator')
-
-@@ -61,10 +60,6 @@ spirv_shader = custom_target('shader_target',
- install : false,
- )
-
--liftoff_proj = subproject('libliftoff', default_options:
-- ['default_library=static'])
--libftoff_dep = liftoff_proj.get_variable('liftoff')
--
- executable(
- 'gamescope',
- 'src/steamcompmgr.cpp',
-@@ -77,8 +72,8 @@ executable(
- dependencies : [
- dep_x11, dep_xdamage, dep_xcomposite, dep_xrender, dep_xext,
- dep_xxf86vm, pixman_dep, drm_dep, wayland_server, wayland_protos,
-- libinput, xkbcommon, math, thread_dep, sdl_dep, wlroots_static_dep,
-- vulkan_dep, libftoff_dep, dep_xtst, cap_dep
-+ libinput, xkbcommon, math, thread_dep, sdl_dep, wlroots,
-+ vulkan_dep, liftoff, dep_xtst, cap_dep
- ],
- install: true,
- )
---
-2.28.0
-