summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSefa Eyeoglu2020-05-20 13:19:53 +0200
committerSefa Eyeoglu2020-05-20 13:19:53 +0200
commit38d648507cff8acd7bcc68b6f4fd3bd0e825cca8 (patch)
tree1ee921bba51b4538f2d7e1604a45ef292bc6e3fc
downloadaur-38d648507cff8acd7bcc68b6f4fd3bd0e825cca8.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD48
-rw-r--r--use-system-wlroots.patch57
3 files changed, 129 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..88743c9a34e3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = gamescope-git
+ pkgdesc = Micro-compositor formerly known as steamcompmgr
+ pkgver = 3.6.1.r24.g66722b1
+ pkgrel = 1
+ url = https://github.com/Plagman/gamescope
+ arch = x86_64
+ license = custom:BSD-2-Clause
+ makedepends = git
+ makedepends = meson
+ makedepends = ninja
+ depends = wlroots-git
+ depends = sdl2
+ depends = libxcomposite
+ depends = vulkan-icd-loader
+ depends = libxtst
+ provides = gamescope
+ conflicts = gamescope
+ source = git+https://github.com/Plagman/gamescope.git
+ source = use-system-wlroots.patch
+ sha512sums = SKIP
+ sha512sums = 6f3b95ac6d95cfc5c1dd82c995b7492505507171f7d4df5c59dba3e8b66eda696328e71fc49e4df8cbf8a7aab252946c9ceb75080d062b30b8cf31dedba58717
+
+pkgname = gamescope-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..05a36c667a81
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Sefa Eyeoglu <contact@scrumplex.net>
+
+_pkgname=gamescope
+pkgname=${_pkgname}-git
+pkgver=3.6.1.r24.g66722b1
+pkgrel=1
+pkgdesc="Micro-compositor formerly known as steamcompmgr"
+arch=(x86_64)
+url="https://github.com/Plagman/gamescope"
+license=("custom:BSD-2-Clause")
+depends=("wlroots-git" "sdl2" "libxcomposite" "vulkan-icd-loader" "libxtst")
+makedepends=("git" "meson" "ninja")
+provides=($_pkgname)
+conflicts=($_pkgname)
+source=("git+https://github.com/Plagman/gamescope.git"
+ "use-system-wlroots.patch")
+sha512sums=('SKIP'
+ '6f3b95ac6d95cfc5c1dd82c995b7492505507171f7d4df5c59dba3e8b66eda696328e71fc49e4df8cbf8a7aab252946c9ceb75080d062b30b8cf31dedba58717')
+
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "$srcdir/$_pkgname"
+
+ git am "../use-system-wlroots.patch"
+
+ git submodule init
+ git submodule update
+}
+
+build() {
+ meson --prefix /usr --buildtype=release "$srcdir/$_pkgname" build
+ ninja -C build
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C build install
+
+ cd "$srcdir/$_pkgname"
+
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 "README.md" "${pkgdir}/usr/share/doc/${_pkgname}/README.md"
+}
diff --git a/use-system-wlroots.patch b/use-system-wlroots.patch
new file mode 100644
index 000000000000..c7bd9d6edbd7
--- /dev/null
+++ b/use-system-wlroots.patch
@@ -0,0 +1,57 @@
+From 159e0a80b83ef9d2a55ef27f4a68c520a04526b4 Mon Sep 17 00:00:00 2001
+From: Sefa Eyeoglu <contact@scrumplex.net>
+Date: Wed, 20 May 2020 12:43:05 +0200
+Subject: [PATCH] packaging/archlinux: Use global wlroots library
+
+---
+ .gitmodules | 3 ---
+ meson.build | 6 ++----
+ subprojects/wlroots | 1 -
+ 3 files changed, 2 insertions(+), 8 deletions(-)
+ delete mode 160000 subprojects/wlroots
+
+diff --git a/.gitmodules b/.gitmodules
+index dcdc8b8..984b052 100644
+--- a/.gitmodules
++++ b/.gitmodules
+@@ -1,6 +1,3 @@
+-[submodule "subprojects/wlroots"]
+- path = subprojects/wlroots
+- url = https://github.com/swaywm/wlroots.git
+ [submodule "subprojects/libliftoff"]
+ path = subprojects/libliftoff
+ url = https://github.com/emersion/libliftoff.git
+diff --git a/meson.build b/meson.build
+index 7d2fd7d..a275d50 100644
+--- a/meson.build
++++ b/meson.build
+@@ -44,9 +44,7 @@ math = cc.find_library('m')
+ thread_dep = dependency('threads')
+ sdl_dep = dependency('SDL2')
+
+-wlroots_proj = subproject('wlroots', default_options:
+- ['default_library=static', 'examples=false'])
+-wlroots_static_dep = wlroots_proj.get_variable('wlroots')
++wlroots = dependency('wlroots')
+
+ shadercompiler = find_program('glslangValidator')
+
+@@ -76,7 +74,7 @@ executable(
+ dependencies : [
+ dep_x11, dep_xdamage, dep_xcomposite, dep_xrender, dep_xext,
+ dep_xxf86vm, pixman_dep, drm_dep, wayland_server, wayland_protos,
+- libinput, xkbcommon, math, thread_dep, sdl_dep, wlroots_static_dep,
++ libinput, xkbcommon, math, thread_dep, sdl_dep, wlroots,
+ vulkan_dep, libftoff_dep, dep_xtst
+ ],
+ install: true,
+diff --git a/subprojects/wlroots b/subprojects/wlroots
+deleted file mode 160000
+index 2176c63..0000000
+--- a/subprojects/wlroots
++++ /dev/null
+@@ -1 +0,0 @@
+-Subproject commit 2176c63856df4e411df0ba3c5eee43f69e977b6e
+--
+2.26.2
+