summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoaquín Ignacio Aramendía2023-05-25 15:23:19 -0300
committerJoaquín Ignacio Aramendía2023-05-25 15:23:41 -0300
commit3efb529ac0a1bd522e6f9bf88c741579fdd4059d (patch)
treebe05720dd11e36e5218d4b85159fa6702c88090d
parent313de6792ca78061e3459c7ea70c5067167871c0 (diff)
downloadaur-3efb529ac0a1bd522e6f9bf88c741579fdd4059d.tar.gz
Remove check and simplify build in line with Valve's package
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD16
2 files changed, 6 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ba3b2b283cfd..38577cf9c279 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gamescope-git
pkgdesc = Micro-compositor formerly known as steamcompmgr
- pkgver = 3.12.0.beta3.r28.g345ffef
+ pkgver = 3.12.0.beta7.r1.g73ce5a4
pkgrel = 1
url = https://github.com/ValveSoftware/gamescope
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 5c147488141d..883b2ff10230 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=gamescope
pkgname=${_pkgname}-git
-pkgver=3.12.0.beta3.r28.g345ffef
+pkgver=3.12.0.beta7.r1.g73ce5a4
pkgrel=1
pkgdesc="Micro-compositor formerly known as steamcompmgr"
arch=(x86_64)
@@ -65,21 +65,15 @@ prepare() {
}
build() {
+ cd "${_pkgname}"
- arch-meson "$srcdir/$_pkgname" build \
- --force-fallback-for=wlroots,libliftoff,stb \
- -Dpipewire=enabled \
- -Dwlroots:backends=drm,libinput,x11 \
- -Dwlroots:renderers=gles2,vulkan
+ arch-meson "$srcdir/$_pkgname" build --buildtype release \
+ --force-fallback-for=wlroots,libliftoff,stb
ninja -C build
}
-check() {
-
- ninja -C build test || true # libdisplay-info tests fail?
-}
-
package() {
+ cd "${_pkgname}"
meson install -C build --skip-subprojects --destdir "$pkgdir"