summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoaquín Ignacio Aramendía2023-06-10 14:52:43 -0300
committerJoaquín Ignacio Aramendía2023-06-10 14:52:43 -0300
commit723bdef093298ca402a5933ec27c8c3d2eda88b6 (patch)
treebea870694d6074a39ea8729116dd8d889109ac5e
parent3efb529ac0a1bd522e6f9bf88c741579fdd4059d (diff)
downloadaur-723bdef093298ca402a5933ec27c8c3d2eda88b6.tar.gz
Revert wlroots flags, some issues arise without them
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 38577cf9c279..6d2768419274 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gamescope-git
pkgdesc = Micro-compositor formerly known as steamcompmgr
- pkgver = 3.12.0.beta7.r1.g73ce5a4
+ pkgver = 3.12.0.beta8.r8.g8866c02
pkgrel = 1
url = https://github.com/ValveSoftware/gamescope
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 883b2ff10230..a5e635a0ce29 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=gamescope
pkgname=${_pkgname}-git
-pkgver=3.12.0.beta7.r1.g73ce5a4
+pkgver=3.12.0.beta8.r8.g8866c02
pkgrel=1
pkgdesc="Micro-compositor formerly known as steamcompmgr"
arch=(x86_64)
@@ -67,8 +67,15 @@ prepare() {
build() {
cd "${_pkgname}"
- arch-meson "$srcdir/$_pkgname" build --buildtype release \
- --force-fallback-for=wlroots,libliftoff,stb
+ export LDFLAGS="$LDFLAGS -lrt"
+
+ arch-meson "$srcdir/$_pkgname" build \
+ --buildtype release \
+ --force-fallback-for=wlroots,libliftoff,stb \
+ -Dpipewire=enabled \
+ -Dwlroots:backends=drm,libinput,x11 \
+ -Dwlroots:renderers=gles2,vulkan
+
ninja -C build
}