summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSefa Eyeoglu2021-07-31 22:33:15 +0200
committerSefa Eyeoglu2021-07-31 22:33:15 +0200
commit7bbf89a5349fc03d68ee97f70bc73e45c0b84f1e (patch)
tree4d3a4eee0d7fad5a5ec88da113fbd91229913b13
parent4e0599406befd0941632fc9e372bcf55ab0bedc0 (diff)
downloadaur-7bbf89a5349fc03d68ee97f70bc73e45c0b84f1e.tar.gz
upgpkg: gamescope-git 3.8.4.r85.g802d86c-1
Statically link wlroots
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD29
2 files changed, 27 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8e8c813f246f..6ee2c2cf03e4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gamescope-git
pkgdesc = Micro-compositor formerly known as steamcompmgr
- pkgver = 3.7.1.r76.gdb14ce1
- pkgrel = 2
+ pkgver = 3.8.4.r85.g802d86c
+ pkgrel = 1
url = https://github.com/Plagman/gamescope
arch = x86_64
license = custom:BSD-2-Clause
@@ -16,8 +16,7 @@ pkgbase = gamescope-git
depends = libxtst
depends = libxres
depends = sdl2
- depends = wlroots=0.13.0
- depends = libliftoff-git
+ depends = libliftoff
provides = gamescope
provides = steamcompmgr
conflicts = gamescope
@@ -26,4 +25,3 @@ pkgbase = gamescope-git
sha512sums = SKIP
pkgname = gamescope-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 30dfff97c3c2..b615ea5f3e49 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,25 @@
# Maintainer: Sefa Eyeoglu <contact@scrumplex.net>
+_static_wlroots=1
+_static_liftoff=0
+
_pkgname=gamescope
pkgname=${_pkgname}-git
-pkgver=3.7.1.r76.gdb14ce1
-pkgrel=2
+pkgver=3.8.4.r85.g802d86c
+pkgrel=1
pkgdesc="Micro-compositor formerly known as steamcompmgr"
arch=(x86_64)
url="https://github.com/Plagman/gamescope"
license=("custom:BSD-2-Clause")
-depends=("libxcomposite" "libxtst" "libxres" "sdl2" "wlroots=0.13.0" "libliftoff-git")
+depends=("libxcomposite" "libxtst" "libxres" "sdl2")
makedepends=("git" "meson" "ninja" "patch" "vulkan-headers" "glslang" "wayland-protocols")
provides=($_pkgname "steamcompmgr")
conflicts=($_pkgname "steamcompmgr")
source=("git+https://github.com/Plagman/gamescope.git")
sha512sums=('SKIP')
+[ $_static_wlroots -gt 0 ] || depends+=("wlroots=0.13.0")
+[ $_static_liftoff -gt 0 ] || depends+=("libliftoff")
pkgver() {
cd "$srcdir/$_pkgname"
@@ -33,12 +38,25 @@ prepare() {
git apply "../$src"
done
- rm -rf "subprojects/libliftoff" "subprojects/wlroots"
+ [ $_static_wlroots -gt 0 ] || rm -rf "subprojects/wlroots"
+ [ $_static_liftoff -gt 0 ] || rm -rf "subprojects/libliftoff"
}
build() {
- meson setup --prefix /usr --buildtype=release --wrap-mode=nodownload "$srcdir/$_pkgname" build
+ _force_static=()
+ [ $_static_wlroots -gt 0 ] && _force_static+=(wlroots)
+ [ $_static_liftoff -gt 0 ] && _force_static+=(libliftoff)
+
+ _force_fallback=$(IFS=, echo "${_force_static[*]}")
+
+ if [ -z "$_force_fallback" ]; then
+ _force_fallback="[]"
+ fi
+
+ echo "Statically linking: $_force_fallback"
+
+ meson setup --prefix /usr --buildtype=release --force-fallback-for=$_force_fallback "$srcdir/$_pkgname" build
ninja -C build
}
@@ -50,6 +68,7 @@ check() {
package() {
DESTDIR="$pkgdir" ninja -C build install
+ rm -rfv "$pkgdir/usr/include/wlr" "$pkgdir/usr/lib/libwlroots*" "$pkgdir/usr/lib/pkgconfig/wlroots.pc"
cd "$srcdir/$_pkgname"