summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSefa Eyeoglu2022-09-03 13:15:55 +0200
committerSefa Eyeoglu2022-09-03 13:15:55 +0200
commita2eb6619b033a550f29372f2ec658c8a1dab221b (patch)
tree4a79c747d87a7a4e86c264ba6bcb05177ed06d2d
parent91d6db462dea67c159b846e0ace235ee5497ac4f (diff)
downloadaur-a2eb6619b033a550f29372f2ec658c8a1dab221b.tar.gz
upgpkg: gamescope-git 3.11.43.r2.gc40c8aa-1
build libliftoff from subproject
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD18
2 files changed, 10 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a45d8e4b3f7d..80db940a3146 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gamescope-git
pkgdesc = Micro-compositor formerly known as steamcompmgr
- pkgver = 3.11.36.r0.gcb59480
+ pkgver = 3.11.43.r2.gc40c8aa
pkgrel = 1
url = https://github.com/Plagman/gamescope
arch = x86_64
@@ -18,7 +18,6 @@ pkgbase = gamescope-git
depends = libxres
depends = sdl2
depends = pipewire
- depends = libliftoff
depends = libdrm
depends = libxkbcommon
depends = libinput
@@ -34,9 +33,11 @@ pkgbase = gamescope-git
conflicts = steamcompmgr
source = gamescope::git+https://github.com/Plagman/gamescope.git
source = git+https://gitlab.freedesktop.org/wlroots/wlroots.git
+ source = git+https://gitlab.freedesktop.org/emersion/libliftoff.git
source = git+https://github.com/nothings/stb.git
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
+ sha512sums = SKIP
pkgname = gamescope-git
diff --git a/PKGBUILD b/PKGBUILD
index 9586ab2f3d97..4f9e84616a18 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=gamescope
pkgname=${_pkgname}-git
-pkgver=3.11.36.r0.gcb59480
+pkgver=3.11.43.r2.gc40c8aa
pkgrel=1
pkgdesc="Micro-compositor formerly known as steamcompmgr"
arch=(x86_64)
@@ -10,7 +10,7 @@ url="https://github.com/Plagman/gamescope"
license=("custom:BSD-2-Clause")
depends=(
# gamescope
- "libxcomposite" "libxtst" "libxres" "sdl2" "pipewire" "libliftoff"
+ "libxcomposite" "libxtst" "libxres" "sdl2" "pipewire"
# wlroots
"libdrm" "libxkbcommon" "libinput" "pixman" "xorg-xwayland" "xcb-util-renderutil" "xcb-util-wm" "xcb-util-errors" "seatd"
)
@@ -19,9 +19,11 @@ provides=($_pkgname "steamcompmgr")
conflicts=($_pkgname "steamcompmgr")
source=("$_pkgname::git+https://github.com/Plagman/gamescope.git"
"git+https://gitlab.freedesktop.org/wlroots/wlroots.git"
+ "git+https://gitlab.freedesktop.org/emersion/libliftoff.git"
"git+https://github.com/nothings/stb.git")
sha512sums=('SKIP'
'SKIP'
+ 'SKIP'
'SKIP')
@@ -44,7 +46,7 @@ prepare() {
git submodule init
git config submodule.subprojects/wlroots.url "$srcdir/wlroots"
- git config submodule.subprojects/libliftoff.active "false"
+ git config submodule.subprojects/libliftoff.url "$srcdir/libliftoff"
git submodule update
# make stb.wrap use our local clone
@@ -55,7 +57,7 @@ prepare() {
build() {
arch-meson "$srcdir/$_pkgname" build \
- --force-fallback-for=wlroots,stb \
+ --force-fallback-for=wlroots,libliftoff,stb \
-Dpipewire=enabled
ninja -C build
}
@@ -67,13 +69,7 @@ check() {
package() {
- DESTDIR="$pkgdir" ninja -C build install
-
- # Delete library files that were linked statically
- rm -rfv "$pkgdir/usr/include/wlr" "$pkgdir/usr/lib/libwlroots.a" "$pkgdir/usr/lib/libwlroots*" "$pkgdir/usr/lib/pkgconfig/wlroots.pc"
-
- # Delete empty directories
- find "$pkgdir" -type d -empty -print -delete
+ meson install -C build --skip-subprojects --destdir "$pkgdir"
cd "$srcdir/$_pkgname"