summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSefa Eyeoglu2021-07-31 23:01:10 +0200
committerSefa Eyeoglu2021-07-31 23:01:10 +0200
commitdce84a1313f4b4d2505cd38fc771300e6369e39f (patch)
treeba9a50e62ccb856710954adef6bb7edc14ad76e1
parent7bbf89a5349fc03d68ee97f70bc73e45c0b84f1e (diff)
downloadaur-dce84a1313f4b4d2505cd38fc771300e6369e39f.tar.gz
upgpkg: gamescope-git 3.8.4.r85.g802d86c-2
Add dependencies for statically linking
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD7
2 files changed, 14 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6ee2c2cf03e4..e41ed51c25c3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gamescope-git
pkgdesc = Micro-compositor formerly known as steamcompmgr
pkgver = 3.8.4.r85.g802d86c
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Plagman/gamescope
arch = x86_64
license = custom:BSD-2-Clause
@@ -12,10 +12,19 @@ pkgbase = gamescope-git
makedepends = vulkan-headers
makedepends = glslang
makedepends = wayland-protocols
+ makedepends = cmake
depends = libxcomposite
depends = libxtst
depends = libxres
depends = sdl2
+ depends = libdrm
+ depends = libxkbcommon
+ depends = libinput
+ depends = pixman
+ depends = xorg-xwayland
+ depends = xcb-util-renderutil
+ depends = xcb-util-wm
+ depends = xcb-util-errors
depends = libliftoff
provides = gamescope
provides = steamcompmgr
diff --git a/PKGBUILD b/PKGBUILD
index b615ea5f3e49..a1cae9e50e99 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ _static_liftoff=0
_pkgname=gamescope
pkgname=${_pkgname}-git
pkgver=3.8.4.r85.g802d86c
-pkgrel=1
+pkgrel=2
pkgdesc="Micro-compositor formerly known as steamcompmgr"
arch=(x86_64)
url="https://github.com/Plagman/gamescope"
@@ -18,8 +18,9 @@ conflicts=($_pkgname "steamcompmgr")
source=("git+https://github.com/Plagman/gamescope.git")
sha512sums=('SKIP')
-[ $_static_wlroots -gt 0 ] || depends+=("wlroots=0.13.0")
-[ $_static_liftoff -gt 0 ] || depends+=("libliftoff")
+[ $_static_wlroots -gt 0 ] && depends+=("libdrm" "libxkbcommon" "libinput" "pixman" "xorg-xwayland" \
+ "xcb-util-renderutil" "xcb-util-wm" "xcb-util-errors") && makedepends+=("cmake") || depends+=("wlroots=0.13.0")
+[ $_static_liftoff -gt 0 ] && depends+=("libdrm") || depends+=("libliftoff")
pkgver() {
cd "$srcdir/$_pkgname"