summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordetiam2024-04-15 10:30:23 +0800
committerdetiam2024-04-15 10:30:23 +0800
commitbce1bfc2d04ae78dd33ad8b0a7e510cc5d94e043 (patch)
tree311386619a5ad7de9c1bc195ee808eee704ae5d9
parentc7f4587950ee105f42dac43e42dce653d0c594ff (diff)
downloadaur-bce1bfc2d04ae78dd33ad8b0a7e510cc5d94e043.tar.gz
stop auto setcap, add a note at installtion time
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--gamescope.install17
3 files changed, 18 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b4691b85a46b..d750a9e94d70 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gamescope-nvidia
pkgdesc = SteamOS session compositing window manager (NVIDIA patch)
pkgver = 3.14.3
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/sharkautarch/gamescope/tree/nvidia-fix
install = gamescope.install
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 25809ca33797..d2ea0b215912 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=gamescope-nvidia
_pkgname=gamescope
pkgver=3.14.3
-pkgrel=1
+pkgrel=2
pkgdesc='SteamOS session compositing window manager (NVIDIA patch)'
arch=(x86_64)
url=https://github.com/sharkautarch/gamescope/tree/nvidia-fix
diff --git a/gamescope.install b/gamescope.install
index 4e54fdfd0ad6..c457e086d980 100644
--- a/gamescope.install
+++ b/gamescope.install
@@ -1,5 +1,20 @@
+all_off="$(tput sgr0)"
+bold="${all_off}$(tput bold)"
+blue="${bold}$(tput setaf 4)"
+yellow="${bold}$(tput setaf 3)"
+
+msg_blue() {
+ printf "${blue}==>${bold} $1${all_off}\n"
+}
+
+note() {
+ printf "${blue}==>${yellow} Note:${bold} $1${all_off}\n"
+}
+
do_setcap() {
- setcap cap_sys_nice=eip $(realpath $(which gamescope))
+ note "${all_off}\"No CAP_SYS_NICE, falling back to regular-priority compute and threads.\""
+ msg_blue 'Use the following command to resolve the above output maybe print by Gamescope, but this probably will cause stutters.'
+ msg_blue "${all_off}setcap cap_sys_nice=eip \"\$(realpath \"\$(which gamescope)\")\""
}
post_install() {