summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoaquín Ignacio Aramendía2022-09-17 18:59:39 -0300
committerJoaquín Ignacio Aramendía2022-09-17 18:59:39 -0300
commit521701756f99e1da8df7fa361dfb5fddd32e2fc5 (patch)
treecb092bebd5ae184a6971a447840c367b88949a46
parent7c6c5f41e5f10e7bca14260b5559f98dbc271bde (diff)
downloadaur-521701756f99e1da8df7fa361dfb5fddd32e2fc5.tar.gz
Update to v3.11.45
-rw-r--r--.SRCINFO10
-rw-r--r--0001-Add-force-orientation-option.patch52
-rw-r--r--0002-Force-orientation-only-to-internal-display.patch8
-rw-r--r--PKGBUILD10
4 files changed, 40 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 59af6666d717..b81f4b3833b9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gamescope-plus
pkgdesc = SteamOS session compositing window manager with added patches
- pkgver = 3.11.43
- pkgrel = 4
+ pkgver = 3.11.45
+ pkgrel = 1
url = https://github.com/Plagman/gamescope
arch = x86_64
license = BSD
@@ -36,11 +36,11 @@ pkgbase = gamescope-plus
depends = xorg-server-xwayland
provides = gamescope
conflicts = gamescope
- source = git+https://github.com/Plagman/gamescope.git#tag=c5269642a293ce5e91d3d644ee15a3f3bcc3c5f3
+ source = git+https://github.com/Plagman/gamescope.git#tag=215a19b0e80cfeb6219c752fcfcf719d5c913432
source = 0001-Add-force-orientation-option.patch
source = 0002-Force-orientation-only-to-internal-display.patch
b2sums = SKIP
- b2sums = 86d47b63f3d2a4d2bc94e30b197ddc4c3563b2e57f0e98537a3eea4dcb90b7b9ba686b44e646f37e41ae46f36c3d33184b66f6597eeefe77b01f2e44c5c84662
- b2sums = d594fc79b9f0a348d2b760aaef0f513c9202de5c5ca8b66575a9b7a3d628be728027a7effa119552616578b4d04bec40dd1f163f7df70d503b9d631280acbab7
+ b2sums = 53ccad968f46ed022ea847d2bc60513b797a054ab105c7e67e384f1ed53cffc814be64d3a699ba0a567076c4205e4c03a07576607b82a2f4f92c0018b2482f53
+ b2sums = f0a9071917387b9025cecf8c4a818b6773947b2996240898439eb3d845a8ffc0f93404b28133a78e96ef5a43ddf00a71e39459e6e0281d5b884efdd3d339720f
pkgname = gamescope-plus
diff --git a/0001-Add-force-orientation-option.patch b/0001-Add-force-orientation-option.patch
index d94c03262a6e..bae85429fca3 100644
--- a/0001-Add-force-orientation-option.patch
+++ b/0001-Add-force-orientation-option.patch
@@ -1,4 +1,4 @@
-From 62ff738299f4ec6331f9ebae569b4e295c15b204 Mon Sep 17 00:00:00 2001
+From 8ced376eb1efece6df825b474f2f2fb1dfb9e863 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Joaqu=C3=ADn=20Ignacio=20Aramend=C3=ADa?=
<samsagax@gmail.com>
Date: Mon, 18 Jul 2022 19:59:41 -0300
@@ -12,11 +12,11 @@ Subject: [PATCH 1/2] Add --force-orientation option
4 files changed, 138 insertions(+), 29 deletions(-)
diff --git a/src/drm.cpp b/src/drm.cpp
-index fce6052..af80966 100644
+index 980e608..c4204be 100644
--- a/src/drm.cpp
+++ b/src/drm.cpp
-@@ -42,6 +42,8 @@ bool g_bDebugLayers = false;
- const char *g_sOutputName = nullptr;
+@@ -48,6 +48,8 @@ const char *g_sOutputName = nullptr;
+ bool g_bSupportsAsyncFlips = false;
enum drm_mode_generation g_drmModeGeneration = DRM_MODE_GENERATE_CVT;
+enum g_panel_orientation g_drmModeOrientation = PANEL_ORIENTATION_AUTO;
@@ -24,7 +24,7 @@ index fce6052..af80966 100644
static LogScope drm_log("drm");
static LogScope drm_verbose_log("drm", LOG_SILENT);
-@@ -1189,7 +1191,7 @@ void drm_lock_fbid( struct drm_t *drm, uint32_t fbid )
+@@ -1256,7 +1258,7 @@ void drm_lock_fbid( struct drm_t *drm, uint32_t fbid )
void drm_unlock_fbid( struct drm_t *drm, uint32_t fbid )
{
struct fb &fb = get_fb( *drm, fbid );
@@ -33,7 +33,7 @@ index fce6052..af80966 100644
assert( fb.held_refs > 0 );
if ( --fb.held_refs != 0 )
return;
-@@ -1230,7 +1232,26 @@ drm_prepare_basic( struct drm_t *drm, const struct FrameInfo_t *frameInfo )
+@@ -1297,7 +1299,26 @@ drm_prepare_basic( struct drm_t *drm, const struct FrameInfo_t *frameInfo )
drm->fbids_in_req.push_back( fb_id );
@@ -61,7 +61,7 @@ index fce6052..af80966 100644
add_plane_property(req, drm->primary, "FB_ID", fb_id);
add_plane_property(req, drm->primary, "CRTC_ID", drm->crtc->id);
-@@ -1480,7 +1501,25 @@ drm_prepare_liftoff( struct drm_t *drm, const struct FrameInfo_t *frameInfo, boo
+@@ -1547,7 +1568,25 @@ drm_prepare_liftoff( struct drm_t *drm, const struct FrameInfo_t *frameInfo, boo
liftoff_layer_set_property( drm->lo_layers[ i ], "SRC_W", entry.layerState[i].srcW );
liftoff_layer_set_property( drm->lo_layers[ i ], "SRC_H", entry.layerState[i].srcH );
@@ -88,7 +88,7 @@ index fce6052..af80966 100644
liftoff_layer_set_property( drm->lo_layers[ i ], "CRTC_X", entry.layerState[i].crtcX);
liftoff_layer_set_property( drm->lo_layers[ i ], "CRTC_Y", entry.layerState[i].crtcY);
-@@ -1957,7 +1996,7 @@ bool drm_update_color_mtx(struct drm_t *drm)
+@@ -2047,7 +2086,7 @@ bool drm_update_color_mtx(struct drm_t *drm)
drm_ctm.matrix[i] = color.s31_32;
}
@@ -97,7 +97,7 @@ index fce6052..af80966 100644
if (drmModeCreatePropertyBlob(drm->fd, &drm_ctm,
sizeof(struct drm_color_ctm), &blob_id) != 0) {
drm_log.errorf_errno("Unable to create CTM property blob");
-@@ -2035,7 +2074,7 @@ bool drm_update_gamma_lut(struct drm_t *drm)
+@@ -2125,7 +2164,7 @@ bool drm_update_gamma_lut(struct drm_t *drm)
gamma_lut[i].blue = drm_calc_lut_value( b_exp, drm->pending.color_linear_gain[2], drm->pending.color_gain[2], drm->pending.gain_blend );
}
@@ -106,7 +106,7 @@ index fce6052..af80966 100644
if (drmModeCreatePropertyBlob(drm->fd, gamma_lut,
lut_entries * sizeof(struct drm_color_lut), &blob_id) != 0) {
drm_log.errorf_errno("Unable to create gamma LUT property blob");
-@@ -2086,7 +2125,7 @@ bool drm_update_degamma_lut(struct drm_t *drm)
+@@ -2176,7 +2215,7 @@ bool drm_update_degamma_lut(struct drm_t *drm)
degamma_lut[i].blue = drm_quantize_lut_value( safe_pow( input, drm->pending.color_degamma_exponent[screen_type][2] ) );
}
@@ -116,10 +116,10 @@ index fce6052..af80966 100644
lut_entries * sizeof(struct drm_color_lut), &blob_id) != 0) {
drm_log.errorf_errno("Unable to create degamma LUT property blob");
diff --git a/src/drm.hpp b/src/drm.hpp
-index 7cf2710..8deb8b2 100644
+index fabda88..a1d2d44 100644
--- a/src/drm.hpp
+++ b/src/drm.hpp
-@@ -86,7 +86,7 @@ struct fb {
+@@ -96,7 +96,7 @@ struct fb {
uint32_t id;
/* Client buffer, if any */
struct wlr_buffer *buf;
@@ -128,7 +128,7 @@ index 7cf2710..8deb8b2 100644
* doesn't need to be atomic as it's only ever
* modified/read from the steamcompmgr thread */
int held_refs;
-@@ -108,19 +108,19 @@ struct drm_t {
+@@ -118,19 +118,19 @@ struct drm_t {
std::unordered_map< uint32_t, struct connector > connectors;
std::map< uint32_t, drmModePropertyRes * > props;
@@ -152,7 +152,7 @@ index 7cf2710..8deb8b2 100644
struct liftoff_device *lo_device;
struct liftoff_output *lo_output;
struct liftoff_layer *lo_layers[ k_nMaxLayers ];
-@@ -158,16 +158,16 @@ struct drm_t {
+@@ -168,16 +168,16 @@ struct drm_t {
std::vector < uint32_t > fbids_queued;
/* FBs currently on screen */
std::vector < uint32_t > fbids_on_screen;
@@ -173,7 +173,7 @@ index 7cf2710..8deb8b2 100644
std::atomic < uint64_t > flipcount;
std::atomic < bool > paused;
-@@ -192,7 +192,16 @@ enum drm_mode_generation {
+@@ -204,7 +204,16 @@ enum drm_mode_generation {
DRM_MODE_GENERATE_FIXED,
};
@@ -191,10 +191,10 @@ index 7cf2710..8deb8b2 100644
bool init_drm(struct drm_t *drm, int width, int height, int refresh);
void finish_drm(struct drm_t *drm);
diff --git a/src/main.cpp b/src/main.cpp
-index a7c6f86..ec94acb 100644
+index 9f88dfc..6ceb80f 100644
--- a/src/main.cpp
+++ b/src/main.cpp
-@@ -78,6 +78,7 @@ const struct option *gamescope_options = (struct option[]){
+@@ -79,6 +79,7 @@ const struct option *gamescope_options = (struct option[]){
{ "composite-debug", no_argument, nullptr, 0 },
{ "disable-xres", no_argument, nullptr, 'x' },
{ "fade-out-duration", required_argument, nullptr, 0 },
@@ -202,7 +202,7 @@ index a7c6f86..ec94acb 100644
{} // keep last
};
-@@ -106,6 +107,7 @@ const char usage[] =
+@@ -107,6 +108,7 @@ const char usage[] =
" -e, --steam enable Steam integration\n"
" --xwayland-count create N xwayland servers\n"
" --prefer-vk-device prefer Vulkan device for compositing (ex: 1002:7300)\n"
@@ -210,7 +210,7 @@ index a7c6f86..ec94acb 100644
"\n"
"Nested mode options:\n"
" -o, --nested-unfocused-refresh game refresh rate when unfocused\n"
-@@ -215,6 +217,22 @@ static enum drm_mode_generation parse_drm_mode_generation(const char *str)
+@@ -217,6 +219,22 @@ static enum drm_mode_generation parse_drm_mode_generation(const char *str)
}
}
@@ -233,7 +233,7 @@ index a7c6f86..ec94acb 100644
static void handle_signal( int sig )
{
switch ( sig ) {
-@@ -369,6 +387,8 @@ int main(int argc, char **argv)
+@@ -371,6 +389,8 @@ int main(int argc, char **argv)
g_nTouchClickMode = g_nDefaultTouchClickMode;
} else if (strcmp(opt_name, "generate-drm-mode") == 0) {
g_drmModeGeneration = parse_drm_mode_generation( optarg );
@@ -242,7 +242,7 @@ index a7c6f86..ec94acb 100644
} else if (strcmp(opt_name, "sharpness") == 0 ||
strcmp(opt_name, "fsr-sharpness") == 0) {
g_upscalerSharpness = atoi( optarg );
-@@ -529,7 +549,7 @@ int main(int argc, char **argv)
+@@ -533,7 +553,7 @@ int main(int argc, char **argv)
fprintf( stderr, "Failed to initialize wlserver\n" );
return 1;
}
@@ -252,7 +252,7 @@ index a7c6f86..ec94acb 100644
setenv("DISPLAY", base_server->get_nested_display_name(), 1);
diff --git a/src/wlserver.cpp b/src/wlserver.cpp
-index 117373e..4edd457 100644
+index 27240ff..0bdb8a4 100644
--- a/src/wlserver.cpp
+++ b/src/wlserver.cpp
@@ -6,7 +6,7 @@
@@ -264,15 +264,15 @@ index 117373e..4edd457 100644
#include <linux/input-event-codes.h>
-@@ -64,6 +64,7 @@ struct wlserver_content_override {
+@@ -65,6 +65,7 @@ struct wlserver_content_override {
enum wlserver_touch_click_mode g_nDefaultTouchClickMode = WLSERVER_TOUCH_CLICK_LEFT;
enum wlserver_touch_click_mode g_nTouchClickMode = g_nDefaultTouchClickMode;
+
static struct wl_list pending_surfaces = {0};
- static void wlserver_surface_set_wlr( struct wlserver_surface *surf, struct wlr_surface *wlr_surf );
-@@ -861,18 +862,38 @@ void wlserver_touchmotion( double x, double y, int touch_id, uint32_t time )
+ static void wlserver_x11_surface_info_set_wlr( struct wlserver_x11_surface_info *surf, struct wlr_surface *wlr_surf );
+@@ -1011,18 +1012,38 @@ void wlserver_touchmotion( double x, double y, int touch_id, uint32_t time )
{
if ( wlserver.mouse_focus_surface != NULL )
{
@@ -317,7 +317,7 @@ index 117373e..4edd457 100644
wlserver.mouse_surface_cursorx = tx;
wlserver.mouse_surface_cursory = ty;
-@@ -900,18 +921,38 @@ void wlserver_touchdown( double x, double y, int touch_id, uint32_t time )
+@@ -1050,18 +1071,38 @@ void wlserver_touchdown( double x, double y, int touch_id, uint32_t time )
{
if ( wlserver.mouse_focus_surface != NULL )
{
diff --git a/0002-Force-orientation-only-to-internal-display.patch b/0002-Force-orientation-only-to-internal-display.patch
index 3d737a7da761..0aa634b918a3 100644
--- a/0002-Force-orientation-only-to-internal-display.patch
+++ b/0002-Force-orientation-only-to-internal-display.patch
@@ -1,4 +1,4 @@
-From 4152008a08bcad741ca8c4a0b977cb1ab5b2c15e Mon Sep 17 00:00:00 2001
+From 9387b3b812eb87ff2c6a3c06b3cf0e04e8a5cba7 Mon Sep 17 00:00:00 2001
From: alphonsez1 <alphonsez743@gmail.com>
Date: Sat, 3 Sep 2022 13:49:11 -0700
Subject: [PATCH 2/2] Force orientation only to internal display.
@@ -8,10 +8,10 @@ Subject: [PATCH 2/2] Force orientation only to internal display.
1 file changed, 51 insertions(+), 34 deletions(-)
diff --git a/src/drm.cpp b/src/drm.cpp
-index af80966..168fb54 100644
+index c4204be..29a3320 100644
--- a/src/drm.cpp
+++ b/src/drm.cpp
-@@ -1232,25 +1232,33 @@ drm_prepare_basic( struct drm_t *drm, const struct FrameInfo_t *frameInfo )
+@@ -1299,25 +1299,33 @@ drm_prepare_basic( struct drm_t *drm, const struct FrameInfo_t *frameInfo )
drm->fbids_in_req.push_back( fb_id );
@@ -62,7 +62,7 @@ index af80966..168fb54 100644
}
add_plane_property(req, drm->primary, "FB_ID", fb_id);
-@@ -1501,25 +1509,34 @@ drm_prepare_liftoff( struct drm_t *drm, const struct FrameInfo_t *frameInfo, boo
+@@ -1568,25 +1576,34 @@ drm_prepare_liftoff( struct drm_t *drm, const struct FrameInfo_t *frameInfo, boo
liftoff_layer_set_property( drm->lo_layers[ i ], "SRC_W", entry.layerState[i].srcW );
liftoff_layer_set_property( drm->lo_layers[ i ], "SRC_H", entry.layerState[i].srcH );
diff --git a/PKGBUILD b/PKGBUILD
index b43a63979582..5e82153a9abc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,8 @@
_pkgname=gamescope
pkgname=gamescope-plus
-pkgver=3.11.43
-pkgrel=4
+pkgver=3.11.45
+pkgrel=1
pkgdesc='SteamOS session compositing window manager with added patches'
arch=(x86_64)
url=https://github.com/Plagman/gamescope
@@ -47,13 +47,13 @@ makedepends=(
ninja
vulkan-headers
)
-_tag=c5269642a293ce5e91d3d644ee15a3f3bcc3c5f3
+_tag=215a19b0e80cfeb6219c752fcfcf719d5c913432
source=("git+https://github.com/Plagman/gamescope.git#tag=${_tag}"
"0001-Add-force-orientation-option.patch"
"0002-Force-orientation-only-to-internal-display.patch")
b2sums=('SKIP'
- '86d47b63f3d2a4d2bc94e30b197ddc4c3563b2e57f0e98537a3eea4dcb90b7b9ba686b44e646f37e41ae46f36c3d33184b66f6597eeefe77b01f2e44c5c84662'
- 'd594fc79b9f0a348d2b760aaef0f513c9202de5c5ca8b66575a9b7a3d628be728027a7effa119552616578b4d04bec40dd1f163f7df70d503b9d631280acbab7')
+ '53ccad968f46ed022ea847d2bc60513b797a054ab105c7e67e384f1ed53cffc814be64d3a699ba0a567076c4205e4c03a07576607b82a2f4f92c0018b2482f53'
+ 'f0a9071917387b9025cecf8c4a818b6773947b2996240898439eb3d845a8ffc0f93404b28133a78e96ef5a43ddf00a71e39459e6e0281d5b884efdd3d339720f')
prepare() {
cd "$srcdir/$_pkgname"