summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhonjow2024-03-04 23:28:08 +0000
committerhonjow2024-03-04 23:28:08 +0000
commit46468a6cf5f9ce9584b14b905be9ea593530360e (patch)
tree74d5695f9dda3237a51f3ea8563c9f89476c38fe
downloadaur-46468a6cf5f9ce9584b14b905be9ea593530360e.tar.gz
Update AUR package
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
-rw-r--r--gamescope-session.install7
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e0e30cafcfc3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = gamescope-session-sk-git
+ pkgdesc = Common gamescope session files
+ pkgver = r223.0dbb596
+ pkgrel = 1
+ url = https://github.com/ChimeraOS/gamescope-session
+ install = gamescope-session.install
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = gamescope
+ source = gamescope-session::git+https://github.com/3003n/gamescope-session.git#branch=dev
+ md5sums = SKIP
+
+pkgname = gamescope-session-sk-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a81fdee4d081
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Joaquín I. Aramendía <samsagax at gmail dot com>
+
+pkgname=gamescope-session-sk-git
+_gitdir=gamescope-session
+pkgver=r223.0dbb596
+pkgrel=1
+pkgdesc="Common gamescope session files"
+arch=('any')
+url="https://github.com/ChimeraOS/gamescope-session"
+license=('MIT')
+groups=()
+depends=('gamescope')
+makedepends=('git')
+install=gamescope-session.install
+source=("${_gitdir}::git+https://github.com/3003n/${_gitdir}.git#branch=dev")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${_gitdir}"
+
+# Git, no tags available
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/${_gitdir}"
+ cp -rv ${srcdir}/${_gitdir}/usr ${pkgdir}/usr
+ install -Dm644 ${srcdir}/${_gitdir}/LICENSE ${pkgdir}/usr/share/licenses/${_gitdir}/LICENSE
+}
diff --git a/gamescope-session.install b/gamescope-session.install
new file mode 100644
index 000000000000..2421f8942521
--- /dev/null
+++ b/gamescope-session.install
@@ -0,0 +1,7 @@
+post_install() {
+ setcap 'cap_sys_nice=eip' /usr/bin/gamescope
+}
+
+post_upgrade() {
+ post_install
+} \ No newline at end of file