summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2023-07-28 16:37:01 +0200
committerMaxime Gauduin2023-07-28 16:37:01 +0200
commitd048a4fc27816508527c0298db45f2faaac8eab8 (patch)
tree03fbdd485d84231920821ca5a6fa8ccfcd32e0c9
parenta3f808682dacc8a96170126c13b7dbdf38b6f08b (diff)
downloadaur-d048a4fc27816508527c0298db45f2faaac8eab8.tar.gz
upgpkg: 3.12.0-1
-rw-r--r--.SRCINFO45
-rw-r--r--PKGBUILD13
2 files changed, 55 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..888b383612ff
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,45 @@
+pkgbase = gamescope
+ pkgdesc = SteamOS session compositing window manager
+ pkgver = 3.12.0
+ pkgrel = 1
+ url = https://github.com/Plagman/gamescope
+ arch = x86_64
+ license = BSD
+ makedepends = benchmark
+ makedepends = git
+ makedepends = glslang
+ makedepends = meson
+ makedepends = ninja
+ makedepends = vulkan-headers
+ makedepends = wayland-protocols
+ depends = gcc-libs
+ depends = glibc
+ depends = glm
+ depends = libcap.so
+ depends = libdisplay-info.so
+ depends = libdrm
+ depends = libliftoff.so
+ depends = libpipewire-0.3.so
+ depends = libvulkan.so
+ depends = libwlroots.so
+ depends = libx11
+ depends = libxcb
+ depends = libxcomposite
+ depends = libxdamage
+ depends = libxext
+ depends = libxfixes
+ depends = libxkbcommon.so
+ depends = libxmu
+ depends = libxrender
+ depends = libxres
+ depends = libxtst
+ depends = libxxf86vm
+ depends = openvr
+ depends = sdl2
+ depends = vulkan-icd-loader
+ depends = wayland
+ depends = xorg-server-xwayland
+ source = git+https://github.com/Plagman/gamescope.git#tag=318fd75952302fb8f121c0fc9a788f38c96a9dba
+ b2sums = SKIP
+
+pkgname = gamescope
diff --git a/PKGBUILD b/PKGBUILD
index 4fa2ed074373..bef10c2323e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: PedroHLC <root@pedrohlc.com>
pkgname=gamescope
-pkgver=3.11.51
+pkgver=3.12.0
pkgrel=1
pkgdesc='SteamOS session compositing window manager'
arch=(x86_64)
@@ -13,42 +13,49 @@ license=(BSD)
depends=(
gcc-libs
glibc
+ glm
libcap.so
+ libdisplay-info.so
libdrm
libliftoff.so
libpipewire-0.3.so
libvulkan.so
libwlroots.so
libx11
+ libxcb
libxcomposite
libxdamage
libxext
libxfixes
libxkbcommon.so
+ libxmu
libxrender
libxres
libxtst
libxxf86vm
+ openvr
sdl2
vulkan-icd-loader
wayland
- wayland-protocols
xorg-server-xwayland
)
makedepends=(
+ benchmark
git
glslang
meson
ninja
vulkan-headers
+ wayland-protocols
)
-_tag=7aef264dfcf81c5f303422d820b7e1ecf81568f3
+_tag=318fd75952302fb8f121c0fc9a788f38c96a9dba
source=(git+https://github.com/Plagman/gamescope.git#tag=${_tag})
b2sums=(SKIP)
prepare() {
cd gamescope
meson subprojects download
+ sed 's/glslangValidator/glslang/g' -i src/meson.build
}
pkgver() {