summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhonjow2024-03-04 04:35:13 +0000
committerhonjow2024-03-04 04:35:13 +0000
commit25211750a708d8f7a0609be8b38dfcff3969a498 (patch)
treef57452970df70becf9bab777b8184c5990aa9d29
downloadaur-25211750a708d8f7a0609be8b38dfcff3969a498.tar.gz
Update AUR package
-rw-r--r--.SRCINFO52
-rw-r--r--PKGBUILD97
2 files changed, 149 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..784ec3e7bc14
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,52 @@
+pkgbase = gamescope-sk-git
+ pkgdesc = SteamOS session compositing window manager
+ pkgver = 3.14.1.r14.gc3c54be
+ pkgrel = 1
+ url = https://github.com/ValveSoftware/gamescope
+ arch = x86_64
+ license = BSD
+ makedepends = benchmark
+ makedepends = cmake
+ makedepends = git
+ makedepends = glslang
+ makedepends = meson
+ makedepends = ninja
+ makedepends = vulkan-headers
+ makedepends = wayland-protocols
+ depends = gcc-libs
+ depends = glibc
+ depends = glm
+ depends = hwdata
+ depends = libavif
+ depends = libcap.so
+ depends = libdisplay-info.so
+ depends = libdrm
+ depends = libliftoff.so
+ depends = libinput
+ depends = libpipewire-0.3.so
+ depends = libvulkan.so
+ depends = libx11
+ depends = libxcb
+ depends = libxcomposite
+ depends = libxdamage
+ depends = libxext
+ depends = libxfixes
+ depends = libxkbcommon
+ depends = libxmu
+ depends = libxrender
+ depends = libxres
+ depends = libxtst
+ depends = libxxf86vm
+ depends = seatd
+ depends = sdl2
+ depends = vulkan-icd-loader
+ depends = wayland
+ depends = xcb-util-wm
+ depends = xcb-util-errors
+ depends = xorg-server-xwayland
+ provides = gamescope
+ conflicts = gamescope
+ source = git+https://github.com/3003n/gamescope.git#bransh=sk-gamscope
+ b2sums = SKIP
+
+pkgname = gamescope-sk-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1010aed66482
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,97 @@
+
+_pkgname=gamescope
+pkgname=${_pkgname}-sk-git
+pkgver=3.14.1.r14.gc3c54be
+pkgrel=1
+pkgdesc='SteamOS session compositing window manager'
+arch=(x86_64)
+url=https://github.com/ValveSoftware/gamescope
+license=(BSD)
+depends=(
+ gcc-libs
+ glibc
+ glm
+ hwdata
+ libavif
+ libcap.so
+ libdisplay-info.so
+ libdrm
+ libliftoff.so
+ libinput
+ libpipewire-0.3.so
+ libvulkan.so
+ libx11
+ libxcb
+ libxcomposite
+ libxdamage
+ libxext
+ libxfixes
+ libxkbcommon
+ libxmu
+ libxrender
+ libxres
+ libxtst
+ libxxf86vm
+ seatd
+ sdl2
+ vulkan-icd-loader
+ wayland
+ xcb-util-wm
+ xcb-util-errors
+ xorg-server-xwayland
+)
+makedepends=(
+ benchmark
+ cmake
+ git
+ glslang
+ meson
+ ninja
+ vulkan-headers
+ wayland-protocols
+)
+_branch=sk-gamscope
+source=("git+https://github.com/3003n/gamescope.git#bransh=${_branch}")
+b2sums=('SKIP')
+
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+
+prepare() {
+ cd $_pkgname
+ # This really should be a pacman feature...
+ for src in "${source[@]}"; do
+ src="${src%%::*}"
+ src="${src##*/}"
+ [[ $src = *.patch ]] || continue
+ echo "Applying patch $src..."
+ git apply "../$src"
+ done
+ meson subprojects download
+ git submodule init
+ git -c protocol.file.allow=always submodule update
+
+ # Use Arch provided libdisplay-info, do use other subprojects as is
+ rm -rf subprojects/libdisplay-info
+}
+
+pkgver() {
+ cd $_pkgname
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ arch-meson "${_pkgname}" build \
+ -Dforce_fallback_for=stb \
+ -Dpipewire=enabled
+ meson compile -C build
+}
+
+package() {
+ meson install -C build --skip-subprojects --destdir="${pkgdir}"
+
+ cd "$srcdir/$_pkgname"
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/$pkgname/"
+}
+
+# vim: ts=2 sw=2 et: \ No newline at end of file