summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhonjow2024-06-25 14:18:15 +0000
committerhonjow2024-06-25 14:18:15 +0000
commit84efd54fb449ab3f302985268435d9966c545deb (patch)
treed5cfcc73eaf92b6473fa8a9969301d6b351dcb62
parent3e767deeebdab104841218379eebf8f86c16ac70 (diff)
downloadaur-84efd54fb449ab3f302985268435d9966c545deb.tar.gz
Update AUR package
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0bae7e33c0fe..f9bb588d757e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -48,8 +48,10 @@ pkgbase = gamescope-sk-git
depends = xorg-server-xwayland
provides = gamescope
conflicts = gamescope
- source = git+https://github.com/3003n/gamescope.git#branch=sk-gamescope
+ source = git+https://github.com/3003n/gamescope.git#tag=
source = git+https://github.com/nothings/stb.git#commit=af1a5bc352164740c1cc1354942b1c6b72eacb8a
+ source = git+https://github.com/Joshua-Ashton/wlroots.git
+ source = git+https://gitlab.freedesktop.org/emersion/libliftoff.git
source = git+https://github.com/Joshua-Ashton/GamescopeShaders.git#tag=v0.1
source = git+https://github.com/Joshua-Ashton/reshade.git
source = git+https://github.com/KhronosGroup/SPIRV-Headers.git
@@ -58,5 +60,7 @@ pkgbase = gamescope-sk-git
b2sums = SKIP
b2sums = SKIP
b2sums = SKIP
+ b2sums = SKIP
+ b2sums = SKIP
pkgname = gamescope-sk-git
diff --git a/PKGBUILD b/PKGBUILD
index bff51ed689ca..fb7b929bab2d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -53,8 +53,10 @@ makedepends=(
)
# _tag=62d425164d383fcde498b17b0af5d00bfa92aed4
_branch="sk-gamescope"
-source=("git+https://github.com/3003n/gamescope.git#branch=${_branch}"
+source=("git+https://github.com/3003n/gamescope.git#tag=${_tag}"
"git+https://github.com/nothings/stb.git#commit=af1a5bc352164740c1cc1354942b1c6b72eacb8a"
+ "git+https://github.com/Joshua-Ashton/wlroots.git"
+ "git+https://gitlab.freedesktop.org/emersion/libliftoff.git"
"git+https://github.com/Joshua-Ashton/GamescopeShaders.git#tag=v0.1"
"git+https://github.com/Joshua-Ashton/reshade.git"
"git+https://github.com/KhronosGroup/SPIRV-Headers.git"
@@ -64,6 +66,8 @@ b2sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
+ 'SKIP'
'SKIP')
provides=("$_pkgname")
@@ -100,11 +104,9 @@ pkgver() {
build() {
export LDFLAGS="$LDFLAGS -lrt"
arch-meson gamescope build \
- -Dforce_fallback_for=stb,libliftoff,wlroots \
+ -Dforce_fallback_for=stb,libliftoff,wlroots,vkroots \
-Dpipewire=enabled \
- -Denable_openvr_support=false \
- -Dwlroots:backends=drm,libinput,x11 \
- -Dwlroots:renderers=gles2,vulkan
+ -Denable_openvr_support=false
ninja -C build
}