summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-06-15 13:12:48 -0600
committerMark Wagie2021-06-15 13:12:48 -0600
commitd23b465c77dca4b7279f1e23b9a6fee6d284934c (patch)
treed5b6601e506276a7a27d3191910cb9929c4fbf95
parent3b08015262d93f2dcc436759c14c063aebc8c09d (diff)
downloadaur-d23b465c77dca4b7279f1e23b9a6fee6d284934c.tar.gz
patch merged upstream
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
2 files changed, 6 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b4ec641bd893..5c07df65f557 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gammy-git
pkgdesc = Adaptive screen brightness/temperature tool.
- pkgver = 0.9.64.r4.gf42577a
- pkgrel = 3
+ pkgver = 0.9.64.r5.g6a34922
+ pkgrel = 1
url = https://getgammy.com
arch = x86_64
license = GPL3
@@ -12,8 +12,6 @@ pkgbase = gammy-git
provides = gammy
conflicts = gammy
source = git+https://github.com/Fushko/gammy.git
- source = https://github.com/Fushko/gammy/pull/119.patch
sha256sums = SKIP
- sha256sums = 8b96a361c39351cde45d73947f55ad1d64b98c43617dad5a3c901c6c668ba1ed
pkgname = gammy-git
diff --git a/PKGBUILD b/PKGBUILD
index 0503605cc4ab..29cda9c32c71 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=gammy-git
-pkgver=0.9.64.r4.gf42577a
-pkgrel=3
+pkgver=0.9.64.r5.g6a34922
+pkgrel=1
pkgdesc="Adaptive screen brightness/temperature tool."
arch=('x86_64')
url="https://getgammy.com"
@@ -10,23 +10,14 @@ depends=('qt5-base' 'hicolor-icon-theme')
makedepends=('git' 'imagemagick')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=('git+https://github.com/Fushko/gammy.git'
- 'https://github.com/Fushko/gammy/pull/119.patch')
-sha256sums=('SKIP'
- '8b96a361c39351cde45d73947f55ad1d64b98c43617dad5a3c901c6c668ba1ed')
+source=('git+https://github.com/Fushko/gammy.git')
+sha256sums=('SKIP')
pkgver() {
cd "$srcdir/${pkgname%-git}"
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
- cd "$srcdir/${pkgname%-git}"
-
- # fix gcc11 compilation error
- patch -Np1 -i $srcdir/119.patch
-}
-
build() {
cd "$srcdir/${pkgname%-git}"
qmake \