summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2023-03-17 12:34:54 -0500
committerLuis Martinez2023-03-17 12:34:54 -0500
commit36470d8beee44bd4eda99670d6128c50c11afbfe (patch)
tree6c21e0427e69a03ea3ac525a825d9720803815e8
parentd0e037dc023d26a90d908ea49bcb069176f62439 (diff)
downloadaur-36470d8beee44bd4eda99670d6128c50c11afbfe.tar.gz
update to 42.4.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD33
2 files changed, 22 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aa794a4eae44..2b4a4daf0b1a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = gams
- pkgdesc = The General Algebraic Modeling System (GAMS) is a high-level modeling system for mathematical optimization.
- pkgver = 28.2.0
+ pkgdesc = A high-level modeling system for mathematical optimization
+ pkgver = 42.4.0
pkgrel = 1
- url = http://www.gams.com/
+ url = https://gams.com/
arch = x86_64
license = custom
+ depends = glibc
options = !strip
- source = https://d37drm4t2jghv5.cloudfront.net/distributions/28.2.0/linux/linux_x64_64_sfx.exe
+ source = gams-42.4.0.exe::https://d37drm4t2jghv5.cloudfront.net/distributions/42.4.0/linux/linux_x64_64_sfx.exe
source = gams-studio.desktop
- sha256sums = 766e23e5f45c991801cf6e1a267962243655cce43210994f68cc632e79113043
+ sha256sums = 59d585307bf171ffa5cbf4ebab62978d3b50287d814648c5cfbdd45714385a7b
sha256sums = 5349929ad07ea8de5e6f1e5d03f264b2fd5afc161b4204981d30fc2ff8faed7e
pkgname = gams
-
diff --git a/PKGBUILD b/PKGBUILD
index a2051642abc6..df73b015a742 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,25 @@
-# Maintainer: gaelic < gaelic at luchmhor dot net>
-# Maintainer: Peter Reschenhofer < peterreschenhofer at gmail dot com >
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: gaelic < gaelic at luchmhor dot net>
+# Contributor: Peter Reschenhofer < peterreschenhofer at gmail dot com >
+
pkgname=gams
-pkgver=28.2.0
+pkgver=42.4.0
pkgrel=1
-pkgdesc="The General Algebraic Modeling System (GAMS) is a high-level modeling system for mathematical optimization."
+pkgdesc='A high-level modeling system for mathematical optimization'
arch=('x86_64')
license=('custom')
-url="http://www.gams.com/"
-depends=()
-conflicts=()
+url='https://gams.com/'
+depends=('glibc')
options=('!strip')
-
-source=("https://d37drm4t2jghv5.cloudfront.net/distributions/${pkgver}/linux/linux_x64_64_sfx.exe"
+source=("$pkgname-$pkgver.exe::https://d37drm4t2jghv5.cloudfront.net/distributions/$pkgver/linux/linux_x64_64_sfx.exe"
"gams-studio.desktop")
-
-sha256sums=("766e23e5f45c991801cf6e1a267962243655cce43210994f68cc632e79113043"
- "5349929ad07ea8de5e6f1e5d03f264b2fd5afc161b4204981d30fc2ff8faed7e")
+sha256sums=('59d585307bf171ffa5cbf4ebab62978d3b50287d814648c5cfbdd45714385a7b'
+ '5349929ad07ea8de5e6f1e5d03f264b2fd5afc161b4204981d30fc2ff8faed7e')
package() {
- install -d ${pkgdir}/{opt/gams,usr/bin}
- cp -r ${srcdir}/gams*_linux_x64_64_sfx/* ${pkgdir}/opt/gams/
- install -Dm644 gams-studio.desktop ${pkgdir}/usr/share/applications/gams-studio.desktop
- ln -s "/opt/gams/gams" "$pkgdir/usr/bin/gams"
- ln -s "/opt/gams/studio/studio.AppImage" "$pkgdir/usr/bin/gams-studio"
+ install -d "$pkgdir/opt/gams" "$pkgdir/usr/bin"
+ cp -a --no-preserve=ownership "gams${pkgver::4}_linux_x64_64_sfx/"* "$pkgdir/opt/gams/"
+ install -Dvm644 gams-studio.desktop -t "$pkgdir/usr/share/applications/"
+ ln -sv "/opt/gams/gams" "$pkgdir/usr/bin/gams"
+ ln -sv "/opt/gams/studio/studio.AppImage" "$pkgdir/usr/bin/gams-studio"
}