summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTobias Gurtzick2018-03-01 16:07:36 +0100
committerTobias Gurtzick2018-03-01 16:11:15 +0100
commit36cd898b1c273860a9624cbadc7501d7ca3b1323 (patch)
treee8a30a8a223b9d3e96f8c4d6f6a2834c76876576
downloadaur-36cd898b1c273860a9624cbadc7501d7ca3b1323.tar.gz
initial commit
Signed-off-by: Tobias Gurtzick <magic@wizardtales.com>
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
-rwxr-xr-xappimagekit-Ganache.desktop9
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..81e4b5bf2756
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ganache
+ pkgdesc = A local Ethereum blockchain
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = http://truffleframework.com/ganache/
+ arch = any
+ license = MIT
+ provides = ganache
+ noextract = ganache-${_pkgver}-x86_64.AppImage
+ options = !strip
+ source = https://github.com/trufflesuite/ganache/releases/download/v1.0.2/ganache-1.0.2-x86_64.AppImage
+ source = appimagekit-Ganache.desktop
+ sha256sums = c92b1e39e882c533ed150770f77755291f31a6f1383767e53800b63115341e37
+ sha256sums = SKIP
+
+pkgname = ganache
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fe8fdb87778c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+pkgname=ganache
+pkgver=1.0.2
+_pkgver=1.0.2
+pkgrel=1
+pkgdesc='A local Ethereum blockchain'
+url='http://truffleframework.com/ganache/'
+arch=('any')
+license=('MIT')
+source=("https://github.com/trufflesuite/ganache/releases/download/v${_pkgver}/ganache-${_pkgver}-x86_64.AppImage"
+"appimagekit-Ganache.desktop"
+)
+sha256sums=('c92b1e39e882c533ed150770f77755291f31a6f1383767e53800b63115341e37'
+SKIP
+)
+noextract=('ganache-${_pkgver}-x86_64.AppImage')
+provides=('ganache')
+options=('!strip')
+
+package() {
+ install -D -m 644 "${srcdir}/ganache-${_pkgver}-x86_64.AppImage" "${pkgdir}/usr/bin/ganache"
+ install -D -m 644 "${srcdir}/appimagekit-Ganache.desktop" "${pkgdir}/usr/share/applications/appimagekit-Ganache.desktop"
+ chmod +x "${pkgdir}/usr/bin/ganache"
+}
+
diff --git a/appimagekit-Ganache.desktop b/appimagekit-Ganache.desktop
new file mode 100755
index 000000000000..9eb23bcc4135
--- /dev/null
+++ b/appimagekit-Ganache.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Ganache
+Comment=Personal Blockchain for Ethereum
+Exec="/usr/bin/ganache" %U
+Terminal=false
+Type=Application
+Icon=appimagekit-Ganache
+Categories=Development;
+TryExec=/usr/bin/ganache