summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCedric Bail2017-11-24 10:33:09 -0800
committerCedric Bail2017-11-24 10:33:09 -0800
commitaa3ecd9e23a098a2daed357d9ad77daf56788f06 (patch)
tree3d7eb1f813a8020a87f49bdce043c75c332dc759
downloadaur-aa3ecd9e23a098a2daed357d9ad77daf56788f06.tar.gz
first try at ganache-cli package for ethereum development tests environment.
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD25
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..608e40c52a5d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = ganache-cli
+ pkgdesc = Personal blockchain for Ethereum development.
+ pkgver = 6.0.3
+ pkgrel = 1
+ url = https://github.com/trufflesuite/ganache-cli
+ arch = any
+ license = MIT
+ makedepends = npm
+ depends = nodejs
+ optdepends = mocha: testing support
+ optdepends = testrpc: testing support
+ optdepends = geth: contract deployment
+ optdepends = parity: contract deployment
+ provides = ganache-cli
+ conflicts = ganache-cli-git
+ noextract = ganache-cli-6.0.3.tgz
+ source = https://registry.npmjs.org/ganache-cli/-/ganache-cli-6.0.3.tgz
+ sha1sums = 8b9da149707daa29c69da26f0582b89c90113b9c
+
+pkgname = ganache-cli
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0735a8e3effe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: bluebugs < cedric dot bail at free dot fr >
+pkgname=ganache-cli
+pkgver=6.0.3
+pkgrel=1
+pkgdesc='Personal blockchain for Ethereum development.'
+url='https://github.com/trufflesuite/ganache-cli'
+arch=('any')
+license=('MIT')
+source=("https://registry.npmjs.org/ganache-cli/-/ganache-cli-${pkgver}.tgz")
+noextract=("ganache-cli-${pkgver}.tgz")
+makedepends=('npm')
+depends=('nodejs')
+conflicts=('ganache-cli-git')
+sha1sums=('8b9da149707daa29c69da26f0582b89c90113b9c')
+provides=('ganache-cli')
+optdepends=('mocha: testing support'
+ 'testrpc: testing support'
+ 'geth: contract deployment'
+ 'parity: contract deployment')
+
+package() {
+ npm install -g --production --prefix "$pkgdir/usr" "ganache-cli-${pkgver}.tgz"
+ tar -xf "ganache-cli-${pkgver}.tgz" package/LICENSE
+ install -D -m644 package/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}