summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTyler Langlois2019-05-09 23:46:05 -0600
committerTyler Langlois2019-05-09 23:46:05 -0600
commit1afa0d2b2a5911752da3eb73608eb440d7de3183 (patch)
treeb71bd6e2698d229eead553f6024d7a2ff457aa97
parent4c95c99ffb9ea522c768a83352fb7c9d1e0e5e80 (diff)
downloadaur-ganglia-minimal.tar.gz
ganglia-minimal: fix sun library in configure step
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD21
2 files changed, 13 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5d657d055fcc..0e4fd5089689 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ganglia-minimal
pkgdesc = A version of the ganglia package without gmetad to reduce dependencies.
pkgver = 3.7.2
- pkgrel = 2
+ pkgrel = 3
url = http://ganglia.sourceforge.net/
install = ganglia.install
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index fb2eadda60dd..c3fec3b625d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=ganglia-minimal
_pkgbase=${pkgname%%-minimal}
pkgver=3.7.2
-pkgrel=2
+pkgrel=3
pkgdesc="A version of the ganglia package without gmetad to reduce dependencies."
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
url="http://ganglia.sourceforge.net/"
@@ -36,14 +36,17 @@ prepare() {
build() {
cd "$srcdir/$_pkgbase-$pkgver"
- ./configure --prefix=/usr \
- --sbindir=/usr/bin \
- --libdir=/usr/lib \
- --sysconfdir=/etc/ganglia \
- --enable-gexec \
- --enable-status \
- --with-python=/usr/bin/python2 \
- --with-systemdsystemunitdir=/usr/lib/systemd/system
+ # Required to work around Sun RPC (ONC/RPC) library errors
+ LDFLAGS=-ltirpc \
+ CFLAGS=-I/usr/include/tirpc \
+ ./configure --prefix=/usr \
+ --sbindir=/usr/bin \
+ --libdir=/usr/lib \
+ --sysconfdir=/etc/ganglia \
+ --enable-gexec \
+ --enable-status \
+ --with-python=/usr/bin/python2 \
+ --with-systemdsystemunitdir=/usr/lib/systemd/system
make
}