summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Krause2018-07-02 22:50:51 +0200
committerChristian Krause2018-07-02 22:54:13 +0200
commit2644551130ca5290557716709bcfdfa940807e4c (patch)
treee6d199d2fec3b4a5ff8491518624906c0cc8605c
parent6379b9b88527d38e71ac0c48294c6c6c1da4460b (diff)
downloadaur-2644551130ca5290557716709bcfdfa940807e4c.tar.gz
ganglia-web-3.7.4-1
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD40
-rw-r--r--configuration.patch20
3 files changed, 25 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 59cdce6cb877..a0a4959c9df3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,19 @@
pkgbase = ganglia-web
pkgdesc = Web front-end to Ganglia (see ganglia package)
- pkgver = 3.7.2
+ pkgver = 3.7.4
pkgrel = 1
- url = http://ganglia.sourceforge.net/
+ url = https://github.com/ganglia/ganglia-web
install = ganglia-web.install
arch = any
license = BSD
depends = ganglia
options = !libtool
options = !strip
- source = http://downloads.sourceforge.net/ganglia/ganglia-web-3.7.2.tar.gz
+ backup = usr/share/webapps/ganglia/conf_default.php
+ source = http://downloads.sourceforge.net/ganglia/ganglia-web-3.7.4.tar.gz
source = ganglia-web.install
- source = configuration.patch
- sha256sums = 98820187c98d24d3645b92d31060623de696dad331a361a19874898339523628
+ sha256sums = 18cac5fd232dbd18cce91a8b107cf0ec254f710797ff56017e0c8f9f7ea26825
sha256sums = b2d01098ffc3998143cbd4cc996f3ce572604b6c29f5c97e917f6de8986131da
- sha256sums = 99991e9a17975b97c1049e7f8d6c92afb8dab75f987b2a13cb8cdf1faf1b1918
pkgname = ganglia-web
diff --git a/PKGBUILD b/PKGBUILD
index fe929d52b8a4..927f10f62f9a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,36 @@
# Maintainer: Tyler Langlois <ty |at| tjll |dot| net>
+# Contributor: Christian Krause ("wookietreiber") <christian.krause@mailbox.org>
+# shellcheck disable=2034
+# shellcheck disable=2148
pkgname=ganglia-web
-pkgver=3.7.2
+pkgver=3.7.4
pkgrel=1
pkgdesc="Web front-end to Ganglia (see ganglia package)"
arch=('any')
-url="http://ganglia.sourceforge.net/"
+url="https://github.com/ganglia/ganglia-web"
license=('BSD')
depends=('ganglia')
options=('!libtool' '!strip')
+backup=(usr/share/webapps/ganglia/conf_default.php)
install='ganglia-web.install'
source=("http://downloads.sourceforge.net/ganglia/$pkgname-$pkgver.tar.gz"
- 'ganglia-web.install'
- 'configuration.patch')
-sha256sums=('98820187c98d24d3645b92d31060623de696dad331a361a19874898339523628'
- 'b2d01098ffc3998143cbd4cc996f3ce572604b6c29f5c97e917f6de8986131da'
- '99991e9a17975b97c1049e7f8d6c92afb8dab75f987b2a13cb8cdf1faf1b1918')
-
-prepare() {
- cd "$srcdir/$pkgname-$pkgver"
-
- for patch in $srcdir/*.patch; do
- msg2 "Applying patch $(basename $patch)"
- patch -Np1 -i $patch
- done
-}
+ 'ganglia-web.install')
+sha256sums=('18cac5fd232dbd18cce91a8b107cf0ec254f710797ff56017e0c8f9f7ea26825'
+ 'b2d01098ffc3998143cbd4cc996f3ce572604b6c29f5c97e917f6de8986131da')
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ # shellcheck disable=2154
+ cd "$srcdir"/$pkgname-$pkgver || exit 1
- mkdir -p "$pkgdir/usr/share/webapps"
- cp -a . "$pkgdir/usr/share/webapps/ganglia"
+ # shellcheck disable=2154
+ make \
+ DESTDIR="$pkgdir" \
+ APACHE_USER=http \
+ GDESTDIR=/usr/share/webapps/ganglia \
+ GMETAD_ROOTDIR=/var/lib/ganglia \
+ GWEB_STATEDIR=/var/lib/ganglia \
+ install
- install -Dm644 COPYING "$pkgdir/usr/share/licenses/${pkgname}/COPYING"
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}
diff --git a/configuration.patch b/configuration.patch
deleted file mode 100644
index 0c6e9604adef..000000000000
--- a/configuration.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/conf_default.php
-+++ b/conf_default.php
-@@ -10,7 +10,7 @@
- # Gmetad-webfrontend version. Used to check for updates.
- #
- $conf['gweb_root'] = dirname(__FILE__);
--$conf['gweb_confdir'] = "/var/lib/ganglia-web";
-+$conf['gweb_confdir'] = "/var/lib/ganglia";
-
- include_once $conf['gweb_root'] . "/version.php";
-
-@@ -326,7 +326,7 @@ $conf['external_location'] = "http://localhost/ganglia-2";
- # From version 3.2, backwards compatibility will be disabled by default.
- # default: true (for gmetad < 3.2)
- # default: false (for gmetad >= 3.2)
--$conf['case_sensitive_hostnames'] = true;
-+$conf['case_sensitive_hostnames'] = false;
-
- # The following property controls whether the graphs contained in metric
- # groups are initially displayed or collapsed