summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Majewski2021-03-26 01:39:11 +0100
committerKevin Majewski2021-03-26 01:39:11 +0100
commitc64fd0b9807cbeee2bb3d6e8f4c552f6bd342479 (patch)
tree164c83f62974cb48696bb81493d9530a8fde22e1
downloadaur-c64fd0b9807cbeee2bb3d6e8f4c552f6bd342479.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD32
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..61dcf7286e73
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = gaphor-git
+ pkgdesc = Gaphor is a UML and SysML modeling application written in Python
+ pkgver = 0.28.7
+ pkgrel = 1
+ url = https://github.com/gaphor/gaphor
+ arch = any
+ license = Apache
+ makedepends = python-pip
+ makedepends = python-poetry
+ depends = python-cairo
+ depends = python-gaphas
+ depends = python-generic
+ depends = python-gobject
+ depends = python-importlib-metadata
+ depends = python-typing_extensions
+ depends = python-tinycss2
+ provides = gaphor
+ conflicts = gaphor
+ source = git+https://github.com/gaphor/gaphor.git
+ b2sums = SKIP
+
+pkgname = gaphor-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0cd96de86d54
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+pkgname=gaphor-git
+_pkgname=gaphor
+pkgver=0.28.7
+pkgrel=1
+pkgdesc='Gaphor is a UML and SysML modeling application written in Python'
+arch=('any')
+url=https://github.com/gaphor/gaphor
+license=('Apache')
+depends=('python-cairo' 'python-gaphas' 'python-generic' 'python-gobject' 'python-importlib-metadata' 'python-typing_extensions' 'python-tinycss2')
+makedepends=('python-pip' 'python-poetry')
+provides=('gaphor')
+conflicts=('gaphor')
+source=("git+https://github.com/gaphor/gaphor.git")
+b2sums=('SKIP')
+
+prepare() {
+ cd ${_pkgname}
+ # Avoid installing files directly under site-packages/
+ sed -i '/include = \["README.md"\]/d' pyproject.toml
+}
+
+build() {
+ cd ${_pkgname}
+ poetry build --format wheel
+}
+
+package() {
+ cd ${_pkgname}
+ export PYTHONHASHSEED=0
+ PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps dist/*.whl
+ install -Dm644 -t "$pkgdir"/usr/share/licenses/${_pkgname} LICENSE.txt
+}