summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuna Jernberg2023-12-31 14:47:39 +0100
committerLuna Jernberg2023-12-31 14:47:39 +0100
commit05e5c558733e4e01b1dd55b2739861d867316230 (patch)
tree06ef14b8bd6d00ea5e4e016aa6e248c3b7d95489
downloadaur-05e5c558733e4e01b1dd55b2739861d867316230.tar.gz
Garagejam 1.0 and create pkgbase
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD31
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fbd9ac5ad156
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = garagejam
+ pkgdesc = GarageJam is Free Software in development for musicians who want to compose, record and share original music to the Internet from the GNOME Desktop.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://wiki.gnome.org/Apps/Garagejam
+ arch = x86_64
+ license = GPL3
+ makedepends = intltool
+ makedepends = itstool
+ makedepends = python
+ depends = libchamplain
+ depends = geoclue
+ depends = gst-plugins-base
+ depends = gst-plugins-bad
+ depends = geocode-glib
+ depends = geocode-glib-2
+ depends = gobject-introspection
+ depends = gstreamer
+ depends = libxml2
+ depends = vorbis-tools
+ depends = pango
+ depends = gtk3
+ source = https://www.garagejam.org/src/garagejam-1.0.0.tar.xz
+ sha256sums = b7008972b167df451b6db9b4cf39b0576d70631f14563b70405cf8f113ed98af
+
+pkgname = garagejam
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0944af680b49
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Luna Jernberg <lunajernberg@gnome.org>
+
+
+pkgname=garagejam
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="GarageJam is Free Software in development for musicians who want to compose, record and share original music to the Internet from the GNOME Desktop."
+arch=('x86_64')
+url="https://wiki.gnome.org/Apps/Garagejam"
+license=(GPL3)
+depends=('libchamplain' 'geoclue' 'gst-plugins-base' 'gst-plugins-bad' 'geocode-glib' 'geocode-glib-2' 'gobject-introspection' 'gstreamer' 'libxml2' 'vorbis-tools' 'pango' 'gtk3')
+makedepends=('intltool' 'itstool' 'python')
+source=(https://www.garagejam.org/src/garagejam-1.0.0.tar.xz)
+sha256sums=('b7008972b167df451b6db9b4cf39b0576d70631f14563b70405cf8f113ed98af')
+
+build() {
+ cd $pkgname-$pkgver
+ ./configure --prefix=/usr --with-recording
+ make
+}
+
+check(){
+ cd $pkgname-$pkgver
+ make check -k
+}
+
+package(){
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+}
+