summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Gamble2015-09-17 09:11:28 +1000
committerMatthew Gamble2015-09-17 09:11:28 +1000
commit8300d240bfc4b60387df188ba1ff74d8364eebcb (patch)
tree945163465059db12cbb36c2054cc21e0c4db4732
downloadaur-garchdeps-git.tar.gz
Initial migration of package to AUR4
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..61e9eb79c19e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = garchdeps-git
+ pkgdesc = Tool that shows dependencies of Arch Linux packages in a graphical format
+ pkgver = 2013.09.21
+ pkgrel = 1
+ url = http://bruno.adele.im/projets/garchdeps
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = python
+ optdepends = graphviz
+ source = git://github.com/badele/garchdeps.git
+ sha256sums = SKIP
+
+pkgname = garchdeps-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..be2070f6746b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Matthew Gamble
+
+pkgname=garchdeps-git
+pkgver=2013.09.21
+pkgrel=1
+pkgdesc="Tool that shows dependencies of Arch Linux packages in a graphical format"
+arch=('any')
+url="http://bruno.adele.im/projets/garchdeps"
+license=('GPL3')
+# Previously graphviz was a hard dependency. This was unnecessary, as the script
+# does not call any graphviz binaries directly as far as I can tell. It just generates
+# files that can be processed by the dot binary.
+depends=('python')
+makedepends=('git')
+optdepends=('graphviz')
+source=('git://github.com/badele/garchdeps.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "garchdeps"
+ git log -1 --format=format:%cd --date=short | sed 's|-|.|g'
+}
+
+package(){
+ cd "$srcdir/garchdeps"
+ install -Dm 755 garchdeps.py $pkgdir/usr/bin/garchdeps.py
+}