summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsolaraquarion2017-02-09 19:22:04 -0500
committersolaraquarion2017-02-09 19:22:04 -0500
commit1f3b192232a321a1aebe48bcc9d3514fcad75a16 (patch)
tree80bfd64e5cd29983b6db5928d013f6d71697c035
downloadaur-1f3b192232a321a1aebe48bcc9d3514fcad75a16.tar.gz
initial revision
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD46
2 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0a46554f9eca
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+# Generated by mksrcinfo v8
+# Fri Feb 10 00:21:59 UTC 2017
+pkgbase = garcon-git
+ pkgdesc = Freedesktop.org compliant menu library
+ pkgver = 0.5.0.67.gba006f7
+ pkgrel = 1
+ url = http://wiki.xfce.org/dev/garcon
+ arch = i686
+ arch = x86_64
+ groups = xfce4-git
+ license = GPL2
+ makedepends = git
+ makedepends = xfce4-dev-tools
+ depends = libxfce4util-git
+ provides = garcon=0.5.0.67.gba006f7
+ conflicts = garcon
+ conflicts = libxfce4menu
+ conflicts = libxfce4menu-git
+ replaces = libxfce4menu
+ replaces = libxfce4menu-git
+ options = !libtool
+ options = !makeflags
+ source = garcon-git::git://git.xfce.org/xfce/garcon
+ sha256sums = SKIP
+ sha512sums = SKIP
+
+pkgname = garcon-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..057d33b8e7ea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Limao Luo <luolimao+AUR@gmail.com>
+#
+# (Added from garcon package)
+# Contributor: Evangelos Foutras <evangelos@foutrelis.com>
+# Contributor: Xavier Devlamynck <magicrhesus@ouranos.be>
+
+_pkgname=garcon
+pkgname=$_pkgname-git
+pkgver=0.5.0.67.gba006f7
+pkgrel=1
+pkgdesc="Freedesktop.org compliant menu library"
+arch=(i686 x86_64)
+license=(GPL2)
+url=http://wiki.xfce.org/dev/$_pkgname
+groups=(xfce4-git)
+depends=(libxfce4util-git)
+makedepends=(git xfce4-dev-tools)
+provides=($_pkgname=$pkgver)
+conflicts=($_pkgname libxfce4menu{,-git})
+replaces=(libxfce4menu{,-git})
+options=(!libtool !makeflags)
+source=($pkgname::git://git.xfce.org/xfce/$_pkgname)
+sha256sums=('SKIP')
+sha512sums=('SKIP')
+
+pkgver() {
+ cd $pkgname/
+ git describe | sed 's/^garcon-//;s/-/./g'
+}
+
+
+build() {
+ cd $pkgname/
+ ./autogen.sh \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --disable-static \
+ --disable-debug
+ make
+}
+
+package() {
+ make -C $pkgname DESTDIR="$pkgdir" install
+}