summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBeej Jorgensen2015-08-17 23:56:01 -0700
committerBeej Jorgensen2015-08-17 23:56:01 -0700
commit72e12f0f47d4a5d0069dd97b4cb408189e9d5a5a (patch)
treedba581f31876828715b5a82f42582dbb652d6da8
downloadaur-72e12f0f47d4a5d0069dd97b4cb408189e9d5a5a.tar.gz
Added to aur4
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD77
-rw-r--r--gargoyle.install10
-rw-r--r--gargoyle.sh2
-rw-r--r--gargoyle.xml49
5 files changed, 171 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6c773353b691
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = gargoyle
+ pkgdesc = Interactive Fiction multi-interpreter that supports all major IF formats.
+ pkgver = 2011.1
+ pkgrel = 4
+ url = https://code.google.com/p/garglk/
+ install = gargoyle.install
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ groups = inform
+ license = GPL
+ makedepends = ftjam
+ makedepends = pkgconfig
+ makedepends = desktop-file-utils
+ depends = gtk2
+ depends = sdl_mixer
+ depends = sdl_sound
+ depends = libvorbis
+ depends = freetype2
+ provides = gargoyle
+ conflicts = gargoyle-mod
+ replaces = gargoyle-mod
+ source = https://garglk.googlecode.com/files/gargoyle-2011.1-sources.zip
+ source = gargoyle.sh
+ source = gargoyle.install
+ source = gargoyle.xml
+ sha512sums = 65159580cf3494944f841c44320135580557258e37ad5523ae3ea30555c19834a2793231a8e42c217e5c1d055d50ed6a20d372d6302e880a2818bc4ea59b226f
+ sha512sums = fbfd04e6d62e469b62263f1fb92b314e825784982be3be9f0e506fe6ff7d367704db907c88ec60fc492f35eaa3548fc3a65fd67d8c4c2be7e35ed87a6c9c3489
+ sha512sums = 1fa602865745c1c9801178ee9b24be86215f2af4f9ee3f4f3b3c0606a87aba32a67c9c5343b481332c8fc97ff6c1a5e447f074d116c0cc5b255af35098096e6e
+ sha512sums = c9924abc48b6dc5025fb83c040a3bdd2a324302d67683645a4fd1d1f3bcfe92c58a9db71c1e41a26afe8a3144e1cdafbc060df2261d93ddac29a9144ae22db71
+
+pkgname = gargoyle
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d2ecc3f5bfbe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,77 @@
+# Maintainer: Beej <beej@beej.us>
+# Previous Maintainer: Michael Smith <michael at diglumi dot com>
+# Previous Maintainer: Marcin Skory <armitage at q84fh dot net>
+# Contributor: Eric Forgeot < http://ifiction.free.fr >
+pkgname=gargoyle
+pkgver=2011.1
+pkgrel=4
+pkgdesc="Interactive Fiction multi-interpreter that supports all major IF formats."
+arch=('i686' 'x86_64' 'armv6h')
+url="https://code.google.com/p/garglk/"
+#alternative url="http://ccxvii.net/gargoyle/"
+license=('GPL')
+depends=('gtk2' 'sdl_mixer' 'sdl_sound' 'libvorbis' 'freetype2')
+#sdl_image ?
+makedepends=('ftjam' 'pkgconfig' 'desktop-file-utils')
+provides=('gargoyle')
+conflicts=('gargoyle-mod')
+replaces=('gargoyle-mod')
+#backup=()
+groups=(inform)
+source=("https://garglk.googlecode.com/files/$pkgname-$pkgver-sources.zip" \
+ "gargoyle.sh" \
+ "gargoyle.install" \
+ "gargoyle.xml")
+install=${pkgname}.install
+sha512sums=('65159580cf3494944f841c44320135580557258e37ad5523ae3ea30555c19834a2793231a8e42c217e5c1d055d50ed6a20d372d6302e880a2818bc4ea59b226f'
+ 'fbfd04e6d62e469b62263f1fb92b314e825784982be3be9f0e506fe6ff7d367704db907c88ec60fc492f35eaa3548fc3a65fd67d8c4c2be7e35ed87a6c9c3489'
+ '1fa602865745c1c9801178ee9b24be86215f2af4f9ee3f4f3b3c0606a87aba32a67c9c5343b481332c8fc97ff6c1a5e447f074d116c0cc5b255af35098096e6e'
+ 'c9924abc48b6dc5025fb83c040a3bdd2a324302d67683645a4fd1d1f3bcfe92c58a9db71c1e41a26afe8a3144e1cdafbc060df2261d93ddac29a9144ae22db71')
+
+build() {
+ cd $srcdir
+ # Remove hardcoded optimisation and replace it with our CFLAGS
+ sed -i "s|OPTIM = -O2 ;|OPTIM = ${CFLAGS} ;|" $srcdir/Jamrules
+ # Required to build with gcc 5
+ sed -i "s|SubDirCcFlags -DSMART_TOKENISER |SubDirCcFlags -fgnu89-inline -DSMART_TOKENISER |" $srcdir/terps/Jamfile
+ jam #|| return 1 # redundant? would be invoked when jam crashed but error code != 0 should crash build() anyway...
+ jam install #|| return 1 # ditto
+}
+
+package() {
+ cd $srcdir
+ # Install proper IF-reading binaries
+ install -dm755 $pkgdir/usr/bin/gargoyle-bins
+ install -m755 $srcdir/build/dist/* $pkgdir/usr/bin/gargoyle-bins/
+ ## hurr, durr, I'm dumb and dirty, gotta clean myself
+ rm $pkgdir/usr/bin/gargoyle-bins/libgarglk.so
+
+ # Install libgarglk library
+ install -dm755 $pkgdir/usr/lib
+ install -m755 $srcdir/build/dist/libgarglk.so $pkgdir/usr/lib
+
+ # Install a launching shell script
+ install -m755 $srcdir/gargoyle.sh $pkgdir/usr/bin/gargoyle
+
+ # Install default config
+ install -dm755 $pkgdir/etc
+ install -m755 $srcdir/garglk/garglk.ini $pkgdir/etc
+
+ # Install desktop icons
+ install -dm755 $pkgdir/usr/share/pixmaps
+ install -m644 $srcdir/garglk/gargoyle-house.png $pkgdir/usr/share/pixmaps/${pkgname}.png
+
+ # Install gargoyle xdg desktop entry
+ ## before that, patch the icon path since we renamed it earlier
+ sed -i 's|Icon=gargoyle-house.png|Icon=gargoyle.png|' $srcdir/garglk/${pkgname}.desktop
+ ## link it with x-interactive-fiction mimetype
+ echo "MimeType=application/x-interactive-fiction">>$srcdir/garglk/${pkgname}.desktop
+ ## and then install it. Yay~ :3
+ install -dm755 $pkgdir/usr/share/applications
+ install -m644 $srcdir/garglk/${pkgname}.desktop $pkgdir/usr/share/applications/${pkgname}.desktop
+
+ # Install mimetype
+ install -dm755 $pkgdir/usr/share/mime/packages
+ install -m644 $srcdir/gargoyle.xml $pkgdir/usr/share/mime/packages/
+}
+
diff --git a/gargoyle.install b/gargoyle.install
new file mode 100644
index 000000000000..2fa8b3794c80
--- /dev/null
+++ b/gargoyle.install
@@ -0,0 +1,10 @@
+post_install() {
+ update-mime-database usr/share/mime > /dev/null
+ update-desktop-database -q
+}
+post_upgrade() {
+ post_install
+}
+post_remove() {
+ post_install
+}
diff --git a/gargoyle.sh b/gargoyle.sh
new file mode 100644
index 000000000000..c49e75626648
--- /dev/null
+++ b/gargoyle.sh
@@ -0,0 +1,2 @@
+#!/bin/sh
+/usr/bin/gargoyle-bins/gargoyle "$@"
diff --git a/gargoyle.xml b/gargoyle.xml
new file mode 100644
index 000000000000..f38e0f9cef05
--- /dev/null
+++ b/gargoyle.xml
@@ -0,0 +1,49 @@
+<?xml version="1.0" encoding="utf-8"?>
+<mime-info xmlns="http://www.freedesktop.org/standards/shared-mime-info">
+ <mime-type type="application/x-interactive-fiction">
+ <comment>Interactive fiction story</comment>
+ <comment xml:lang="en">Interactive fiction story</comment>
+ <comment xml:lang="pl">Plik fikcji interaktywnej</comment>
+ <icon name="gargoyle"/>
+ <!--blorbs-->
+ <glob pattern="*.blb"/>
+ <glob pattern="*.blorb"/>
+ <glob pattern="*.[zg]blorb"/>
+ <glob pattern="*.glb"/>
+ <glob pattern="*.gbl"/>
+ <glob pattern="*.zlb"/>
+ <glob pattern="*.zbl"/>
+ <!--ADVSYS-->
+ <glob pattern="*.dat"/>
+ <!--AGT-->
+ <glob pattern="*.agx"/>
+ <glob pattern="*.d$$"/>
+ <!--ALAN-->
+ <glob pattern="*.acd"/>
+ <glob pattern="*.a3c"/>
+ <!--ADRIFT-->
+ <glob pattern="*.taf"/>
+ <!--glulx-->
+ <glob pattern="*.ulx"/>
+ <!--HUGO-->
+ <glob pattern="*.hex"/>
+ <!--JACL-->
+ <glob pattern="*.jacl"/>
+ <glob pattern="*.j2"/>
+ <!--TADS-->
+ <glob pattern="*.gam"/>
+ <glob pattern="*.t3"/>
+ <!--Z-Code-->
+ <glob pattern="*.z[12345678]"/>
+ <!--Level9-->
+ <glob pattern="*.l9"/>
+ <glob pattern="*.sna"/>
+ <!--Magnetic-->
+ <glob pattern="*.mag"/>
+ <!--Quest-->
+ <glob pattern="*.asl"/>
+ <glob pattern="*.cas"/>
+ <!--SCOTT-->
+ <glob pattern="*.saga"/>
+ </mime-type>
+</mime-info>