summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSpaghettiCat2016-09-18 11:11:40 +0200
committerSpaghettiCat2016-09-18 11:11:56 +0200
commit22d3b5dc1abb4dba1ee3c1ac68d7bfea3ab4d77c (patch)
tree955cea3fd332b886e71578703de0918fbfc08932
downloadaur-22d3b5dc1abb4dba1ee3c1ac68d7bfea3ab4d77c.tar.gz
Initial commit
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD87
-rw-r--r--gargoyle-git.install10
-rw-r--r--gargoyle.sh2
-rw-r--r--gargoyle.xml49
5 files changed, 183 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ade42acb1988
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+pkgbase = gargoyle-git
+ pkgdesc = Interactive Fiction multi-interpreter that supports all major IF formats (development version)
+ pkgver = 20160918.67251c3
+ pkgrel = 5
+ url = https://github.com/garglk/garglk
+ install = gargoyle-git.install
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ groups = inform
+ license = GPL
+ makedepends = ftjam
+ makedepends = pkgconfig
+ makedepends = desktop-file-utils
+ depends = gtk2
+ depends = sdl_mixer
+ depends = sdl_sound
+ depends = libvorbis
+ depends = freetype2
+ provides = gargoyle-git
+ conflicts = gargoyle-mod
+ conflicts = gargoyle
+ replaces = gargoyle-mod
+ replaces = gargoyle
+ source = gargoyle-git::git+https://github.com/garglk/garglk.git
+ source = gargoyle.sh
+ source = gargoyle-git.install
+ source = gargoyle.xml
+ sha512sums = SKIP
+ sha512sums = fbfd04e6d62e469b62263f1fb92b314e825784982be3be9f0e506fe6ff7d367704db907c88ec60fc492f35eaa3548fc3a65fd67d8c4c2be7e35ed87a6c9c3489
+ sha512sums = 1fa602865745c1c9801178ee9b24be86215f2af4f9ee3f4f3b3c0606a87aba32a67c9c5343b481332c8fc97ff6c1a5e447f074d116c0cc5b255af35098096e6e
+ sha512sums = c9924abc48b6dc5025fb83c040a3bdd2a324302d67683645a4fd1d1f3bcfe92c58a9db71c1e41a26afe8a3144e1cdafbc060df2261d93ddac29a9144ae22db71
+
+pkgname = gargoyle-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..33e1adc09b6d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,87 @@
+# Maintainer: SpaghettiCat <d_the_m101 at yahoo dot co dot uk>
+# Based on "gargoyle" package maintained by:
+# Beej <beej@beej.us>
+# Michael Smith <michael at diglumi dot com>
+# Marcin Skory <armitage at q84fh dot net>
+# with Contribution of Eric Forgeot < http://ifiction.free.fr >
+pkgname=gargoyle-git
+pkgver=20160918.67251c3
+pkgrel=5
+pkgdesc="Interactive Fiction multi-interpreter that supports all major IF formats (development version)"
+arch=('i686' 'x86_64' 'armv6h')
+url="https://github.com/garglk/garglk"
+license=('GPL')
+depends=('gtk2' 'sdl_mixer' 'sdl_sound' 'libvorbis' 'freetype2')
+#sdl_image ?
+makedepends=('ftjam' 'pkgconfig' 'desktop-file-utils')
+provides=('gargoyle-git')
+conflicts=('gargoyle-mod' 'gargoyle')
+replaces=('gargoyle-mod' 'gargoyle')
+#backup=()
+groups=(inform)
+source=("$pkgname::git+https://github.com/garglk/garglk.git" \
+ "gargoyle.sh" \
+ "gargoyle-git.install" \
+ "gargoyle.xml")
+install=${pkgname}.install
+sha512sums=('SKIP'
+ 'fbfd04e6d62e469b62263f1fb92b314e825784982be3be9f0e506fe6ff7d367704db907c88ec60fc492f35eaa3548fc3a65fd67d8c4c2be7e35ed87a6c9c3489'
+ '1fa602865745c1c9801178ee9b24be86215f2af4f9ee3f4f3b3c0606a87aba32a67c9c5343b481332c8fc97ff6c1a5e447f074d116c0cc5b255af35098096e6e'
+ 'c9924abc48b6dc5025fb83c040a3bdd2a324302d67683645a4fd1d1f3bcfe92c58a9db71c1e41a26afe8a3144e1cdafbc060df2261d93ddac29a9144ae22db71')
+
+prepare() {
+ cd "$pkgname"
+ # Remove hardcoded optimisation and replace it with our CFLAGS.
+ # Doesn't build with C++14 because of "exception cleanup for this placement
+ # new selects non-placement operator delete" errors.
+ sed -i 's|OPTIM = -O2 $(CFLAGS) ;|OPTIM = ${CFLAGS} -std=c++11 ;|' Jamrules
+ # Required to build with gcc 5
+ sed -i "s|SubDirCcFlags -DSMART_TOKENISER |SubDirCcFlags -fgnu89-inline -DSMART_TOKENISER |" terps/Jamfile
+}
+
+build() {
+ cd "$pkgname"
+ # For whatever reason, jam doesn't seem to take the job number setting from
+ # /etc/makepkg.conf . 4 is a good compromise.
+ jam -j 4
+ jam install
+}
+
+package() {
+ local gsrcdir="$pkgname"
+
+ # Install proper IF-reading binaries
+ install -dm755 "$pkgdir/usr/bin/gargoyle-bins"
+ install -m755 "$gsrcdir"/build/dist/* "$pkgdir/usr/bin/gargoyle-bins/"
+ ## hurr, durr, I'm dumb and dirty, gotta clean myself
+ rm "$pkgdir/usr/bin/gargoyle-bins/libgarglk.so"
+
+ # Install libgarglk library
+ install -dm755 "$pkgdir/usr/lib"
+ install -m755 "$gsrcdir/build/dist/libgarglk.so" "$pkgdir/usr/lib"
+
+ # Install a launching shell script
+ install -m755 "gargoyle.sh" "$pkgdir/usr/bin/gargoyle"
+
+ # Install default config
+ install -dm755 "$pkgdir/etc"
+ install -m755 "$gsrcdir/garglk/garglk.ini" "$pkgdir/etc"
+
+ # Install desktop icons
+ install -dm755 "$pkgdir/usr/share/pixmaps"
+ install -m644 "$gsrcdir/garglk/gargoyle-house.png" "$pkgdir/usr/share/pixmaps/${pkgname}.png"
+
+ # Install gargoyle xdg desktop entry
+ ## before that, patch the icon path since we renamed it earlier
+ sed -i 's|Icon=gargoyle-house.png|Icon=gargoyle.png|' "$gsrcdir/garglk/gargoyle.desktop"
+ ## link it with x-interactive-fiction mimetype
+ echo "MimeType=application/x-interactive-fiction" >> "$gsrcdir/garglk/gargoyle.desktop"
+ ## and then install it. Yay~ :3
+ install -dm755 "$pkgdir/usr/share/applications"
+ install -m644 "$gsrcdir/garglk/gargoyle.desktop" "$pkgdir/usr/share/applications/gargoyle.desktop"
+
+ # Install mimetype
+ install -dm755 "$pkgdir/usr/share/mime/packages"
+ install -m644 "gargoyle.xml" "$pkgdir/usr/share/mime/packages/"
+}
+
diff --git a/gargoyle-git.install b/gargoyle-git.install
new file mode 100644
index 000000000000..2fa8b3794c80
--- /dev/null
+++ b/gargoyle-git.install
@@ -0,0 +1,10 @@
+post_install() {
+ update-mime-database usr/share/mime > /dev/null
+ update-desktop-database -q
+}
+post_upgrade() {
+ post_install
+}
+post_remove() {
+ post_install
+}
diff --git a/gargoyle.sh b/gargoyle.sh
new file mode 100644
index 000000000000..c49e75626648
--- /dev/null
+++ b/gargoyle.sh
@@ -0,0 +1,2 @@
+#!/bin/sh
+/usr/bin/gargoyle-bins/gargoyle "$@"
diff --git a/gargoyle.xml b/gargoyle.xml
new file mode 100644
index 000000000000..f38e0f9cef05
--- /dev/null
+++ b/gargoyle.xml
@@ -0,0 +1,49 @@
+<?xml version="1.0" encoding="utf-8"?>
+<mime-info xmlns="http://www.freedesktop.org/standards/shared-mime-info">
+ <mime-type type="application/x-interactive-fiction">
+ <comment>Interactive fiction story</comment>
+ <comment xml:lang="en">Interactive fiction story</comment>
+ <comment xml:lang="pl">Plik fikcji interaktywnej</comment>
+ <icon name="gargoyle"/>
+ <!--blorbs-->
+ <glob pattern="*.blb"/>
+ <glob pattern="*.blorb"/>
+ <glob pattern="*.[zg]blorb"/>
+ <glob pattern="*.glb"/>
+ <glob pattern="*.gbl"/>
+ <glob pattern="*.zlb"/>
+ <glob pattern="*.zbl"/>
+ <!--ADVSYS-->
+ <glob pattern="*.dat"/>
+ <!--AGT-->
+ <glob pattern="*.agx"/>
+ <glob pattern="*.d$$"/>
+ <!--ALAN-->
+ <glob pattern="*.acd"/>
+ <glob pattern="*.a3c"/>
+ <!--ADRIFT-->
+ <glob pattern="*.taf"/>
+ <!--glulx-->
+ <glob pattern="*.ulx"/>
+ <!--HUGO-->
+ <glob pattern="*.hex"/>
+ <!--JACL-->
+ <glob pattern="*.jacl"/>
+ <glob pattern="*.j2"/>
+ <!--TADS-->
+ <glob pattern="*.gam"/>
+ <glob pattern="*.t3"/>
+ <!--Z-Code-->
+ <glob pattern="*.z[12345678]"/>
+ <!--Level9-->
+ <glob pattern="*.l9"/>
+ <glob pattern="*.sna"/>
+ <!--Magnetic-->
+ <glob pattern="*.mag"/>
+ <!--Quest-->
+ <glob pattern="*.asl"/>
+ <glob pattern="*.cas"/>
+ <!--SCOTT-->
+ <glob pattern="*.saga"/>
+ </mime-type>
+</mime-info>