summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSpaghettiCat2021-02-10 18:20:11 +0000
committerSpaghettiCat2021-02-10 18:20:11 +0000
commit445dd4c1eef574de69f74dda8d88a3d955fc769c (patch)
treebcde2afc5112901e6bb48edbec95e38096c79c8e
parent19210ed0bfa564514b29e4f34bd4464f946bff83 (diff)
downloadaur-445dd4c1eef574de69f74dda8d88a3d955fc769c.tar.gz
Update dependencies to GTK3 and SDL2
-rw-r--r--PKGBUILD8
1 files changed, 3 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 71d712eb5862..53244668400c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,13 +11,11 @@ pkgdesc="Interactive Fiction multi-interpreter that supports all major IF format
arch=('i686' 'x86_64' 'armv6h')
url="https://github.com/garglk/garglk"
license=('GPL')
-depends=('gtk2' 'sdl_mixer' 'sdl_sound' 'libvorbis' 'freetype2')
-#sdl_image ?
+depends=('gtk3' 'sdl2_mixer' 'sdl2' 'libvorbis' 'freetype2')
makedepends=('ftjam' 'pkgconfig' 'desktop-file-utils' 'git')
provides=('gargoyle-git')
conflicts=('gargoyle-mod' 'gargoyle')
replaces=('gargoyle-mod' 'gargoyle')
-#backup=()
groups=(inform)
source=("$pkgname::git+https://github.com/garglk/garglk.git" \
"gargoyle.sh" \
@@ -43,7 +41,7 @@ package() {
# Install proper IF-reading binaries
install -dm755 "$pkgdir/usr/bin/gargoyle-bins"
install -m755 "$gsrcdir"/build/dist/* "$pkgdir/usr/bin/gargoyle-bins/"
- ## hurr, durr, I'm dumb and dirty, gotta clean myself
+ ## Have to clean ourselves first.
rm "$pkgdir/usr/bin/gargoyle-bins/libgarglk.so"
# Install libgarglk library
@@ -66,7 +64,7 @@ package() {
sed -i 's|Icon=gargoyle-house.png|Icon=gargoyle.png|' "$gsrcdir/garglk/gargoyle.desktop"
## link it with x-interactive-fiction mimetype
echo "MimeType=application/x-interactive-fiction" >> "$gsrcdir/garglk/gargoyle.desktop"
- ## and then install it. Yay~ :3
+ ## and then install it.
install -dm755 "$pkgdir/usr/share/applications"
install -m644 "$gsrcdir/garglk/gargoyle.desktop" "$pkgdir/usr/share/applications/gargoyle.desktop"