summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSpaghettiCat2020-02-23 13:45:03 +0000
committerSpaghettiCat2020-02-23 13:45:03 +0000
commit6349675e00f1764cd106c43b00aca949f3b8029b (patch)
tree4c86dab264484289d541bca25b333aef400bd0a9
parente10a9b5fbaf0de1381560b2f419b519c1d3a7870 (diff)
downloadaur-6349675e00f1764cd106c43b00aca949f3b8029b.tar.gz
Remove unnecessary prepare() steps
From "TheCycoOne": > Neither of the prepare changes are needed: > > https://github.com/garglk/garglk/commit/be9ae55dd206f103ec686cb3faaf2d505098547f handled the C++11 issue. > > I'm not sure about the inline issue, but I compiled fine without it, and they don't use it with gcc6 in their travis builds.
-rw-r--r--PKGBUILD12
1 files changed, 1 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2b0f7c02e528..71d712eb5862 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
# with Contribution of Eric Forgeot < http://ifiction.free.fr >
pkgname=gargoyle-git
pkgver=20160918.67251c3
-pkgrel=2
+pkgrel=3
pkgdesc="Interactive Fiction multi-interpreter that supports all major IF formats (development version)"
arch=('i686' 'x86_64' 'armv6h')
url="https://github.com/garglk/garglk"
@@ -29,16 +29,6 @@ sha512sums=('SKIP'
'1fa602865745c1c9801178ee9b24be86215f2af4f9ee3f4f3b3c0606a87aba32a67c9c5343b481332c8fc97ff6c1a5e447f074d116c0cc5b255af35098096e6e'
'c9924abc48b6dc5025fb83c040a3bdd2a324302d67683645a4fd1d1f3bcfe92c58a9db71c1e41a26afe8a3144e1cdafbc060df2261d93ddac29a9144ae22db71')
-prepare() {
- cd "$pkgname"
- # Remove hardcoded optimisation and replace it with our CFLAGS.
- # Doesn't build with C++14 because of "exception cleanup for this placement
- # new selects non-placement operator delete" errors.
- sed -i 's|OPTIM = -O2 $(CFLAGS) ;|OPTIM = ${CFLAGS} -std=c++11 ;|' Jamrules
- # Required to build with gcc 5
- sed -i "s|SubDirCcFlags -DSMART_TOKENISER |SubDirCcFlags -fgnu89-inline -DSMART_TOKENISER |" terps/Jamfile
-}
-
build() {
cd "$pkgname"
# For whatever reason, jam doesn't seem to take the job number setting from