summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Rembrandt2016-12-14 17:04:32 +0000
committerAndrew Rembrandt2016-12-14 17:04:32 +0000
commit7fc7f9dcec37b8028b46642f625aef705dd030e0 (patch)
tree0880a3c65c4934eddaf01e59aa333761828128c3
downloadaur-7fc7f9dcec37b8028b46642f625aef705dd030e0.tar.gz
Restored package from AUR archive
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD23
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..242f5104a758
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = garminplugin
+ pkgdesc = Garmin Communicator Plugin for Linux
+ pkgver = 0.3.27
+ pkgrel = 1
+ url = http://www.andreas-diesner.de/garminplugin/doku.php
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = garmintools
+ depends = tinyxml
+ depends = libusb
+ source = https://github.com/adiesner/GarminPlugin/archive/V0.3.27.zip
+ sha256sums = 5487a1d3242f3d35bbf2830bae5fa5e84cec9245f0da87c90ca2d9a3ca225be0
+
+pkgname = garminplugin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6250600a449e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+pkgname=garminplugin
+pkgrel=1
+pkgver=0.3.27
+pkgdesc="Garmin Communicator Plugin for Linux"
+arch=('i686' 'x86_64')
+url="http://www.andreas-diesner.de/garminplugin/doku.php"
+license=('GPL')
+depends=("garmintools" "tinyxml" "libusb")
+source=(https://github.com/adiesner/GarminPlugin/archive/V${pkgver}.zip)
+sha256sums=('5487a1d3242f3d35bbf2830bae5fa5e84cec9245f0da87c90ca2d9a3ca225be0')
+
+build() {
+ cd ${srcdir}/GarminPlugin-${pkgver}/src
+ ./configure CXXFLAGS="-fPIC -g -O2" CFLAGS="-g -O2 -fPIC"
+ make
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/lib/mozilla/plugins/"
+ mv -v "${srcdir}/GarminPlugin-${pkgver}/src/npGarminPlugin.so" "$pkgdir/usr/lib/mozilla/plugins/"
+
+}
+