summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan2019-05-01 18:33:40 +1000
committerDan2019-05-01 18:33:40 +1000
commitec585e0692e7811ac46344103c012936ac326d82 (patch)
tree732eef4f5e139d88baee8b9bf4be5371deb50fdf
downloadaur-ec585e0692e7811ac46344103c012936ac326d82.tar.gz
Initial commit V0.9
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD23
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..88dd4fc36b4f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = gashell
+ pkgdesc = A bash script that generates and securely manages/stores Google Authenticator codes.
+ pkgver = 0.9
+ pkgrel = 1
+ url = https://github.com/TechtonicSoftware/GAShell
+ arch = x86_64
+ arch = i686
+ license = GNU V3
+ depends = sed
+ depends = oath-toolkit
+ depends = openssl
+ depends = zbar
+ depends = curl
+ provides = gashell
+ source = https://github.com/TechtonicSoftware/GAShell/archive/0.9.tar.gz
+ sha256sums = 668f68968f0887156b1ab1fede366f62a3275f2e47ba4e8ea3ffc291aa5ea51f
+
+pkgname = gashell
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4c2741b4939d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# $Id$
+# Maintainer: Doctorzeus <simmlog@gmail.com>
+
+pkgname=gashell
+_pkgname=GAShell
+pkgver=0.9
+pkgrel=1
+pkgdesc="A bash script that generates and securely manages/stores Google Authenticator codes."
+arch=('x86_64' 'i686')
+url="https://github.com/TechtonicSoftware/GAShell"
+license=('GNU V3')
+depends=('sed' 'oath-toolkit' 'openssl' 'zbar' 'curl')
+provides=('gashell')
+source=(https://github.com/TechtonicSoftware/$_pkgname/archive/$pkgver.tar.gz)
+sha256sums=('668f68968f0887156b1ab1fede366f62a3275f2e47ba4e8ea3ffc291aa5ea51f')
+
+package() {
+ mkdir -p "$pkgdir/usr/share/$pkgname/";
+ mkdir -p "$pkgdir/bin/";
+
+ cp -R "$srcdir/$_pkgname-$pkgver/$pkgname.sh" "$pkgdir/usr/share/$pkgname/";
+ ln -s "/usr/share/$pkgname/$pkgname.sh" "$pkgdir/bin/$pkgname";
+} \ No newline at end of file