summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTioDuke2015-06-09 21:04:13 -0400
committerTioDuke2015-06-09 21:04:13 -0400
commit47155294cefe2d6a605d3c408f24b64ad806180a (patch)
tree7f9e2bf68d1457f1bf4a50d101cf14e19ebebf9d
downloadaur-47155294cefe2d6a605d3c408f24b64ad806180a.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD46
-rw-r--r--gate.desktop8
-rw-r--r--gate.pngbin0 -> 3132 bytes
4 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..36b81093e819
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = gate
+ pkgdesc = GATE Developer is a development environment that provides a rich set of graphical interactive tools for the creation, measurement and maintenance of software components for processing human language.
+ pkgver = 8.1
+ pkgrel = 1
+ url = http://gate.ac.uk/
+ arch = any
+ license = LGPL
+ depends = java-runtime
+ options = !strip
+ source = http://downloads.sourceforge.net/sourceforge/gate/gate-8.1-build5169-BIN.zip
+ source = gate.desktop
+ source = gate.png
+ md5sums = 8502db86975056410fb500993e2d727e
+ md5sums = a7a2cb37bf093d4b4164c7d381661f33
+ md5sums = acf3e7a9fcbdedd24589394260d56d12
+
+pkgname = gate
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4c8a60ebd0b5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Contributor: Sergio Tridente <tioduke AT gmail DOT com>
+
+pkgname=gate
+pkgver=8.1
+_build=5169
+pkgrel=1
+pkgdesc="GATE Developer is a development environment that provides a rich set of graphical interactive tools for the creation, measurement and maintenance of software components for processing human language."
+arch=('any')
+url="http://gate.ac.uk/"
+license=('LGPL')
+depends=('java-runtime')
+options=(!strip)
+source=(http://downloads.sourceforge.net/sourceforge/${pkgname}/${pkgname}-${pkgver}-build${_build}-BIN.zip gate.desktop gate.png)
+md5sums=('8502db86975056410fb500993e2d727e'
+ 'a7a2cb37bf093d4b4164c7d381661f33'
+ 'acf3e7a9fcbdedd24589394260d56d12')
+
+build() {
+ rm -rf $srcdir/${pkgname}-${pkgver}-build${_build}-BIN/GATE.app
+ find $srcdir/${pkgname}-${pkgver}-build${_build}-BIN -name "*.bat" -type f -exec rm {} \;
+ find $srcdir/${pkgname}-${pkgver}-build${_build}-BIN -name "*.cmd" -type f -exec rm {} \;
+ find $srcdir/${pkgname}-${pkgver}-build${_build}-BIN -name "*.exe" -type f -exec rm {} \;
+}
+
+package() {
+ mkdir -p $pkgdir/usr/share/java/${pkgname}/
+ mkdir -p $pkgdir/usr/bin/
+ mkdir -p $pkgdir/usr/share/doc/${pkgname}/
+ mkdir -p $pkgdir/usr/share/doc/${pkgname}/lib/
+ mkdir -p $pkgdir/usr/share/{pixmaps,applications}
+
+ cp -r $srcdir/${pkgname}-${pkgver}-build${_build}-BIN/* $pkgdir/usr/share/java/${pkgname}/
+ find $pkgdir/usr/share/java/${pkgname} -type f -exec chmod 644 {} \;
+ find $pkgdir/usr/share/java/${pkgname} -type d -exec chmod 755 {} \;
+ find $pkgdir/usr/share/java/${pkgname} -name "*.pl" -type f -exec chmod 755 {} \;
+ find $pkgdir/usr/share/java/${pkgname} -type f -exec egrep -q "#\! ?/bin/(ba)?sh" {} \; -exec chmod 755 {} \;
+
+ ln -s /usr/share/java/${pkgname}/bin/gate.sh $pkgdir/usr/bin/${pkgname}
+
+ mv $pkgdir/usr/share/java/${pkgname}/{licence.html,tao.pdf} $pkgdir/usr/share/doc/${pkgname}/
+ mv $pkgdir/usr/share/java/${pkgname}/lib/{ivy-report.css,*.html} $pkgdir/usr/share/doc/${pkgname}/lib/
+
+ cd $srcdir
+ install -Dm644 gate.png $pkgdir/usr/share/pixmaps/
+ install -Dm644 gate.desktop $pkgdir/usr/share/applications/
+}
diff --git a/gate.desktop b/gate.desktop
new file mode 100644
index 000000000000..72ee172a1852
--- /dev/null
+++ b/gate.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Encoding=UTF-8
+Type=Application
+Name=GATE
+Comment=General architecture for text engineering
+Exec=gate
+Icon=gate
+Categories=Development;IDE;
diff --git a/gate.png b/gate.png
new file mode 100644
index 000000000000..eb1e75f66c76
--- /dev/null
+++ b/gate.png
Binary files differ