summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2015-05-13 22:33:56 +0200
committerNarrat2015-05-13 22:33:56 +0200
commit52b18a1f67f0e6b79004bbef578417d3d674de27 (patch)
treef6388a1fe5efab7210c7be06850c1022025a694c
downloadaur-52b18a1f67f0e6b79004bbef578417d3d674de27.tar.gz
gate88: Latest files
History: https://github.com/Narrat/PKGBuilds
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore14
-rw-r--r--PKGBUILD53
-rwxr-xr-xgate8828
-rw-r--r--gate88.desktop11
-rw-r--r--gate88.pngbin0 -> 4767 bytes
6 files changed, 130 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..09352ee8b424
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = gate88
+ pkgdesc = An abstract realtime strategy/action game in space
+ pkgver = Mar19_05
+ pkgrel = 2
+ url = http://www.queasygames.com/gate88/
+ arch = i686
+ groups = games
+ license = custom
+ depends = sdl
+ depends = sdl_mixer
+ depends = sdl_net
+ depends = libvorbis
+ depends = mesa
+ source = http://www.queasygames.com/gate88/Gate88_Mar19_05.tar.gz
+ source = gate88
+ source = gate88.desktop
+ source = gate88.png
+ md5sums = 57b3d8432462954947b8737bbab81e91
+ md5sums = ec20608ab2f0b34625befd31aae03bcb
+ md5sums = ed2f767b002d320631952d4bf3bf2ac9
+ md5sums = c193292eea050401134ef3c83ba07a0e
+
+pkgname = gate88
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3a3642b6f6ff
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,14 @@
+*/src
+*/pkg
+*.gz
+*.xz
+*.bz2
+*.zip
+*.part
+*.sig
+*.sign
+*.txt
+*.log
+*.scm
+*/*.pkg
+*/*.asc
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e00184ec1e5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Contributor: Lex Black <autumn-wind at web dot de>
+# Contributor: Typhoon
+# Contributer: Klepto <geomoch@gmail.com>
+
+pkgname=gate88
+pkgver=Mar19_05
+pkgrel=2
+pkgdesc="An abstract realtime strategy/action game in space"
+arch=('i686')
+url="http://www.queasygames.com/gate88/"
+license="custom"
+groups=('games')
+depends=(sdl sdl_mixer sdl_net libvorbis mesa)
+source=(http://www.queasygames.com/gate88/Gate88_$pkgver.tar.gz
+ gate88
+ gate88.desktop
+ gate88.png)
+md5sums=('57b3d8432462954947b8737bbab81e91'
+ 'ec20608ab2f0b34625befd31aae03bcb'
+ 'ed2f767b002d320631952d4bf3bf2ac9'
+ 'c193292eea050401134ef3c83ba07a0e')
+
+
+package() {
+ chmod -R a+r $srcdir/Gate88_$pkgver
+ chmod a+x $srcdir/Gate88_$pkgver/sound \
+ $srcdir/Gate88_$pkgver/music \
+ $srcdir/Gate88_$pkgver/music/non-ingame
+
+ mkdir -p $pkgdir/usr/share/$pkgname/lib \
+ $pkgdir/usr/share/applications \
+ $pkgdir/usr/share/licenses/$pkgname \
+ $pkgdir/etc/$pkgname \
+ $pkgdir/etc/rc.d \
+ $pkgdir/usr/bin
+
+ cp -a $srcdir/Gate88_${pkgver}/music \
+ $srcdir/Gate88_${pkgver}/sound \
+ $srcdir/Gate88_${pkgver}/gate88 \
+ $pkgdir/usr/share/$pkgname
+
+ cp $srcdir/Gate88_${pkgver}/lib/libstdc++-libc6.2-2.so.3 \
+ $pkgdir/usr/share/$pkgname/lib
+
+ cp $srcdir/Gate88_${pkgver}/*.conf $pkgdir/etc/$pkgname
+ cp $srcdir/Gate88_${pkgver}/license.txt \
+ $pkgdir/usr/share/licenses/$pkgname
+
+ cp $srcdir/$pkgname.png $pkgdir/usr/share/$pkgname
+ cp $srcdir/$pkgname.desktop $pkgdir/usr/share/applications
+ cp $srcdir/$pkgname $pkgdir/usr/bin
+}
+
diff --git a/gate88 b/gate88
new file mode 100755
index 000000000000..f6c7c1e59c19
--- /dev/null
+++ b/gate88
@@ -0,0 +1,28 @@
+#!/bin/bash
+
+# create the ~/.gate88 directory if needed
+if [ ! -d ~/.gate88 ]; then
+ mkdir -p ~/.gate88/replays
+ ln -s /usr/share/gate88/gate88 \
+ /usr/share/gate88/music \
+ /usr/share/gate88/sound \
+ ~/.gate88
+
+ cp /etc/gate88/audio.conf \
+ /etc/gate88/irc_client.conf \
+ /etc/gate88/multiplayer.conf \
+ /etc/gate88/practice.conf \
+ /etc/gate88/video.conf \
+ /etc/gate88/server.conf \
+ ~/.gate88
+
+ ln -s /etc/gate88/colours.conf \
+ /etc/gate88/textcolours.conf \
+ /etc/gate88/debug.conf \
+ /etc/gate88/irc_connection.conf \
+ /etc/gate88/masterserver.conf \
+ ~/.gate88
+fi
+
+export LD_LIBRARY_PATH="$LD_LIBRARY_PATH:/usr/share/gate88/lib"
+cd ~/.gate88 && ./gate88 "$@"
diff --git a/gate88.desktop b/gate88.desktop
new file mode 100644
index 000000000000..639e406ff155
--- /dev/null
+++ b/gate88.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Gate 88
+Comment=Abstract real time action/strategy in space
+Exec=gate88
+StartupNotify=false
+Terminal=false
+Type=Application
+Categories=Game;Strategy;
+Icon=/usr/share/gate88/gate88.png
+GenericName=Game
diff --git a/gate88.png b/gate88.png
new file mode 100644
index 000000000000..c8ce51f612ea
--- /dev/null
+++ b/gate88.png
Binary files differ