summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2016-04-17 17:37:37 -0600
committerBrian Bidulock2016-04-17 17:37:37 -0600
commit9c4f9ae868ad49d8e6c47cde35825c77c62e3597 (patch)
tree9a82f8fc91a300efd35a80ec1b37cc9388f8e032
downloadaur-9c4f9ae868ad49d8e6c47cde35825c77c62e3597.tar.gz
initial version
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD34
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d8e5b280fb08
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Sun Apr 17 23:37:37 UTC 2016
+pkgbase = gatotray-git
+ pkgdesc = Graphical CPU stats monitor in the system tray.
+ pkgver = 2.3.20.g41b3022
+ pkgrel = 1
+ url = http://code.google.com/p/gatotray/
+ arch = x86_64
+ arch = i686
+ license = CCPL:by
+ makedepends = git
+ depends = gtk2
+ depends = xterm
+ provides = gatotray
+ conflicts = gatotray
+ source = gatotray-git::git+https://github.com/kafene/gatotray.git/
+ md5sums = SKIP
+
+pkgname = gatotray-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bcfa3cebc920
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Brin Bidulock <bidulock@openss7.com>
+# Contributor: Chuan Ji <jichuan89[at]gmail[dot]com>
+pkgname=gatotray-git
+_pkgname=gatotray
+pkgver=2.3.20.g41b3022
+pkgrel=1
+pkgdesc="Graphical CPU stats monitor in the system tray."
+url="http://code.google.com/p/gatotray/"
+arch=('x86_64' 'i686')
+license=('CCPL:by')
+provides=($_pkgname)
+conflicts=($_pkgname)
+depends=('gtk2' 'xterm')
+makedepends=('git')
+source=("$pkgname::git+https://github.com/kafene/$_pkgname.git/")
+md5sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname}
+ printf "2.3.%s.g%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd ${pkgname}
+ make
+}
+
+package() {
+ cd ${pkgname}
+ strip gatotray
+ install -Dm755 gatotray "${pkgdir}/usr/bin/gatotray"
+}
+
+# vim:set ts=2 sw=2 et: