summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2020-07-01 02:04:41 +0200
committerhaawda2020-07-01 02:04:41 +0200
commit64d75f5f462bffe95013812f653fc29c936ac52c (patch)
treead42f582d6b0f5ee0d2be46824777f04348ba664
parent9be6dbed979c3b3f7a4915407f6d803a6533b455 (diff)
downloadaur-64d75f5f462bffe95013812f653fc29c936ac52c.tar.gz
seems to need LANG=C now
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 57654d43498d..95ba2a6383cd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,7 +9,7 @@ pkgbase = gauche-git
license = BSD
makedepends = bash
makedepends = git
- depends = zlib
+ depends = mbedtls
depends = gdbm
depends = libatomic_ops
depends = gauche
diff --git a/PKGBUILD b/PKGBUILD
index 695d8de79b95..f76486ceb4a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,14 +11,13 @@ url='http://practical-scheme.net/gauche/index.html'
license=('BSD')
# gauche only needed if this is the first build of gauche-git,
# afterwards gauche-git will provide gauche
-depends=('zlib' 'gdbm' 'libatomic_ops' 'gauche' 'slib')
+depends=('mbedtls' 'gdbm' 'libatomic_ops' 'gauche' 'slib')
makedepends=('bash' 'git')
provides=('gauche')
conflicts=('gauche')
source=('git+https://github.com/shirok/Gauche.git')
md5sums=('SKIP')
_gitname='Gauche'
-#options=('!makeflags' '!emptydirs')
pkgver() {
cd "$_gitname"
@@ -28,6 +27,7 @@ pkgver() {
build() {
cd "$_gitname"
+ LANG=C
./DIST gen
CONFIG_SHELL=/bin/bash ./configure --prefix=/usr \
--enable-multibyte=utf-8 --enable-threads=pthreads