summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbertabus2017-11-10 12:47:23 -0700
committerbertabus2017-11-10 12:47:23 -0700
commit099768413fa5caa1d74c93a6e5e7761de09494e8 (patch)
tree1a34336009614c2623c3b05fa4e308f0487a0db5
downloadaur-099768413fa5caa1d74c93a6e5e7761de09494e8.tar.gz
initial commit
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD51
2 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ff21baeafdc4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = gaviewer
+ pkgdesc = Geometric Algebra scriptable 3D visualization tool
+ pkgver = 0.86
+ pkgrel = 3
+ url = http://www.geometricalgebra.net/downloads.html
+ arch = x86_64
+ groups = ypb
+ groups = math
+ license = GPL2
+ makedepends = antlr2
+ makedepends = zlib
+ depends = fltk
+ depends = libgl
+ depends = mesa
+ depends = libx11
+ depends = libpng
+ depends = gcc-libs
+ source = http://www.geometricalgebra.net/downloads/GAViewer-0.86.tar.gz
+ source = http://www.geometricalgebra.net/downloads/figures.zip
+ source = http://www.geometricalgebra.net/downloads/gaviewer.pdf
+ source = http://www.geometricalgebra.net/downloads/gaviewerexercises.pdf
+ md5sums = ce5285dfa74db56a4ba7577a1a5e6738
+ md5sums = 172fc88d38e3b29960e33788a1a4f045
+ md5sums = 43fd8ca7da3e0cac3fee2350d05c9d3e
+ md5sums = 60543f7f310292e9c70e9d98dd095c9e
+
+pkgname = gaviewer
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..99995f2753bd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Billy Rond <billy dot rond at gmail dot com>
+# Maintainer: Previously Michal Kowalski <kowalski TOD michal TA gmail TOD com>
+
+pkgname=gaviewer
+_rpkgname=GAViewer
+pkgver=0.86
+pkgrel=3
+epoch=
+pkgdesc="Geometric Algebra scriptable 3D visualization tool"
+arch=('x86_64')
+url="http://www.geometricalgebra.net/downloads.html"
+license=('GPL2')
+groups=('ypb' 'math')
+depends=('fltk' 'libgl' 'mesa' 'libx11' 'libpng' 'gcc-libs')
+makedepends=('antlr2' 'zlib')
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=(http://www.geometricalgebra.net/downloads/${_rpkgname}-$pkgver.tar.gz
+ http://www.geometricalgebra.net/downloads/figures.zip
+ http://www.geometricalgebra.net/downloads/gaviewer.pdf
+ http://www.geometricalgebra.net/downloads/gaviewerexercises.pdf)
+noextract=()
+md5sums=('ce5285dfa74db56a4ba7577a1a5e6738'
+ '172fc88d38e3b29960e33788a1a4f045'
+ '43fd8ca7da3e0cac3fee2350d05c9d3e'
+ '60543f7f310292e9c70e9d98dd095c9e')
+
+build() {
+ cd "$srcdir/${_rpkgname}-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/${_rpkgname}-$pkgver"
+ make DESTDIR="$pkgdir/" install
+ mkdir -p "$pkgdir/usr/share/doc/$pkgname"
+ cp $srcdir/gaviewer.pdf $srcdir/gaviewerexercises.pdf \
+ "$pkgdir/usr/share/doc/$pkgname/"
+ chmod -x $srcdir/Figures/*
+ cp -r $srcdir/Figures "$pkgdir/usr/share/doc/$pkgname/Figures"
+}
+
+# vim:set ts=2 sw=2 et: \ No newline at end of file