summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick McCarty2017-09-18 20:55:11 -0700
committerPatrick McCarty2017-09-18 20:55:11 -0700
commit4204ae23736c721fac4eb2fc5ec40d6c646c4905 (patch)
treeaf7920941eadfd773a986a078e2a95b381c69429
downloadaur-4204ae23736c721fac4eb2fc5ec40d6c646c4905.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD30
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..753befdc8e05
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Tue Sep 19 03:55:04 UTC 2017
+pkgbase = gawk-errno
+ pkgdesc = GAWK extension - convert errno values to strings and vice versa
+ pkgver = 1.0.3
+ pkgrel = 1
+ url = https://sourceforge.net/projects/gawkextlib/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = gawkextlib
+ source = https://downloads.sourceforge.net/gawkextlib/gawk-errno-1.0.3.tar.gz
+ md5sums = 40026e0feb28ce7ef1ff10481f16af84
+ sha256sums = ff3ecc2fd233fb4b49b7158e4f2c6153d2311c143d88a02b61202317d64a8953
+
+pkgname = gawk-errno
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2b022307d03e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.pkg.tar.xz
+*.tar.gz
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..806be30454c9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Patrick McCarty <pnorcks at gmail dot com>
+
+pkgname=gawk-errno
+_project=gawkextlib
+pkgver=1.0.3
+pkgrel=1
+pkgdesc="GAWK extension - convert errno values to strings and vice versa"
+arch=('i686' 'x86_64')
+url="https://sourceforge.net/projects/gawkextlib/"
+license=('GPL')
+depends=('gawkextlib')
+source=("https://downloads.sourceforge.net/$_project/$pkgname-$pkgver.tar.gz")
+md5sums=('40026e0feb28ce7ef1ff10481f16af84')
+sha256sums=('ff3ecc2fd233fb4b49b7158e4f2c6153d2311c143d88a02b61202317d64a8953')
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ make -k check
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}