summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick McCarty2018-01-24 23:12:54 -0800
committerPatrick McCarty2018-01-24 23:15:08 -0800
commita58d78fb9c61ec71d62463f63a4a925b2330c64d (patch)
treea1d5caeb2adeaebabee458074ee12f7ded8e368a
downloadaur-a58d78fb9c61ec71d62463f63a4a925b2330c64d.tar.gz
Import release 1.0.1
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD30
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d4b55de92cb9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Thu Jan 25 07:14:48 UTC 2018
+pkgbase = gawk-json
+ pkgdesc = GAWK extension - interface to RapidJSON for reading/writing JSON
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://sourceforge.net/projects/gawkextlib/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = rapidjson
+ depends = gawkextlib
+ source = https://downloads.sourceforge.net/gawkextlib/gawk-json-1.0.1.tar.gz
+ md5sums = 6b1cf5b55396d5e0f22d729f131a5ff3
+ sha256sums = 3613e1ad22ee7769b81ebccb7e4cd68d7bd84555a58675592b1dbd67c5557683
+
+pkgname = gawk-json
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2b022307d03e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.pkg.tar.xz
+*.tar.gz
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a6f43ffe7ccb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Patrick McCarty <pnorcks at gmail dot com>
+
+pkgname=gawk-json
+_project=gawkextlib
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="GAWK extension - interface to RapidJSON for reading/writing JSON"
+arch=('i686' 'x86_64')
+url="https://sourceforge.net/projects/gawkextlib/"
+license=('GPL')
+depends=('rapidjson' 'gawkextlib')
+source=("https://downloads.sourceforge.net/$_project/$pkgname-$pkgver.tar.gz")
+md5sums=('6b1cf5b55396d5e0f22d729f131a5ff3')
+sha256sums=('3613e1ad22ee7769b81ebccb7e4cd68d7bd84555a58675592b1dbd67c5557683')
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ make -k check
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}