summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2019-08-14 09:16:05 -0400
committeracxz2019-08-14 09:16:05 -0400
commit4d803f06ad225484408f2150aed19ad65351d05b (patch)
tree1f10fc79f501d25673199e445f2f109dbac30b2f
parentd1481457803619117b5f0b6774ebc78729a75aa6 (diff)
downloadaur-4d803f06ad225484408f2150aed19ad65351d05b.tar.gz
Updated package deps
-rw-r--r--.SRCINFO47
-rw-r--r--PKGBUILD17
2 files changed, 35 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5e1f83a457d2..abd23cef8544 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gazebo-hg
pkgdesc = A multi-robot simulator for outdoor environments. Mercurial version.
- pkgver = 6.0.0.19165
+ pkgver = 11.0.0.38446
pkgrel = 1
url = http://gazebosim.org/
install = gazebo.install
@@ -9,33 +9,38 @@ pkgbase = gazebo-hg
license = Apache
makedepends = cmake
makedepends = doxygen
+ makedepends = ignition-cmake=0
makedepends = mercurial
- makedepends = pkg-config>=0.26
- depends = boost>=1.40.0
- depends = curl>=4.0
+ depends = boost
+ depends = curl
depends = freeglut
- depends = freeimage>=3.0
- depends = intel-tbb>=3.0
- depends = libccd>=1.4
- depends = libltdl>=2.4.2
- depends = libtar>=1.2
- depends = libxml2>=2.7.7
- depends = ogre
- depends = protobuf>=2.3.0
- depends = qt4
- depends = sdformat>=2.0.1
- depends = tinyxml>=2.6.2
- optdepends = bullet>=2.82: Bullet support
- optdepends = cegui-0.7>=0.7.5: Design custom graphical interfaces
- optdepends = ffmpeg>=0.8.3: Playback movies on textured surfaces
+ depends = freeimage
+ depends = intel-tbb
+ depends = libccd
+ depends = libltdl
+ depends = libtar
+ depends = libxml2
+ depends = ogre=1.9
+ depends = protobuf
+ depends = sdformat=6
+ depends = ignition-math=4
+ depends = ignition-transport=4
+ depends = ignition-common=1
+ depends = ignition-fuel_tools=1
+ depends = ignition-msgs=1
+ depends = tinyxml2
+ depends = qwt
+ optdepends = bullet: Bullet support
+ optdepends = cegui: Design custom graphical interfaces
+ optdepends = ffmpeg: Playback movies on textured surfaces
optdepends = gdal: Digital elevation terrains support
- optdepends = libdart>=3.0: DART support
+ optdepends = libdart: DART support
+ optdepends = libspnav: space navigator joystick support
optdepends = libusb: USB peripherals support
optdepends = ruby-ronn: Generate manpages
- optdepends = simbody>=3.3: Simbody support
+ optdepends = simbody: Simbody support
optdepends = urdfdom: Load URDF files
provides = gazebo
- conflicts = gazebo
source = gazebo::hg+https://bitbucket.org/osrf/gazebo#branch=default
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 5b5f2aca89da..c41bbae21bc3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,18 @@
+# Maintainer: acxz <akashpatel2008 at yahoo dot com>
# Contributor: Aris Synodinos <arissynod-gmail-com>
+
pkgname=gazebo-hg
-pkgver=10.0.1.37153
+pkgver=11.0.0.38446
pkgrel=1
pkgdesc="A multi-robot simulator for outdoor environments. Mercurial version."
arch=('i686' 'x86_64')
url="http://gazebosim.org/"
license=('Apache')
-# See: http://www.gazebosim.org/user_guide/installation__requirements.html
-depends=('boost>=1.40.0' 'curl>=4.0' 'freeglut' 'freeimage>=3.0'
- 'intel-tbb>=3.0' 'libccd>=1.4' 'libltdl>=2.4.2' 'libtar>=1.2' 'libxml2>=2.7.7'
- 'ogre' 'protobuf>=2.3.0' 'sdformat>=6.0.0' 'ignition-math>=4' 'ignition-transport>=4'
- 'ignition-common' 'ignition-fuel_tools' 'ignition-msgs' 'tinyxml2' 'qwt')
+# See: http://www.gazebosim.org/tutorials?tut=install_from_source&cat=install
+depends=('boost' 'curl' 'freeglut' 'freeimage' 'intel-tbb' 'libccd' 'libltdl'
+ 'libtar' 'libxml2' 'ogre=1.9' 'protobuf' 'sdformat=6' 'ignition-math=4'
+ 'ignition-transport=4' 'ignition-common=1' 'ignition-fuel_tools=1'
+ 'ignition-msgs=1' 'tinyxml2' 'qwt')
optdepends=('bullet: Bullet support'
'cegui: Design custom graphical interfaces'
'ffmpeg: Playback movies on textured surfaces'
@@ -21,10 +23,9 @@ optdepends=('bullet: Bullet support'
'ruby-ronn: Generate manpages'
'simbody: Simbody support'
'urdfdom: Load URDF files')
-makedepends=('cmake' 'doxygen' 'mercurial' 'pkgconf>=0.26')
+makedepends=('cmake' 'doxygen' 'ignition-cmake=0' 'mercurial')
install="gazebo.install"
provides=('gazebo')
-conflicts=('gazebo')
_hgrepo=gazebo
_hgroot=https://bitbucket.org/osrf