summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Chrétien2015-06-21 17:19:21 +0900
committerBenjamin Chrétien2015-06-21 17:19:21 +0900
commitadc5c2e8436af4538a85f3c42a6a05f398c324cb (patch)
treea42873d2d42b78f1b1493c72f16824a549f6147d
downloadaur-adc5c2e8436af4538a85f3c42a6a05f398c324cb.tar.gz
Initial commit
-rw-r--r--.SRCINFO43
-rw-r--r--PKGBUILD68
-rw-r--r--gazebo.install6
3 files changed, 117 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5e1f83a457d2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,43 @@
+pkgbase = gazebo-hg
+ pkgdesc = A multi-robot simulator for outdoor environments. Mercurial version.
+ pkgver = 6.0.0.19165
+ pkgrel = 1
+ url = http://gazebosim.org/
+ install = gazebo.install
+ arch = i686
+ arch = x86_64
+ license = Apache
+ makedepends = cmake
+ makedepends = doxygen
+ makedepends = mercurial
+ makedepends = pkg-config>=0.26
+ depends = boost>=1.40.0
+ depends = curl>=4.0
+ depends = freeglut
+ depends = freeimage>=3.0
+ depends = intel-tbb>=3.0
+ depends = libccd>=1.4
+ depends = libltdl>=2.4.2
+ depends = libtar>=1.2
+ depends = libxml2>=2.7.7
+ depends = ogre
+ depends = protobuf>=2.3.0
+ depends = qt4
+ depends = sdformat>=2.0.1
+ depends = tinyxml>=2.6.2
+ optdepends = bullet>=2.82: Bullet support
+ optdepends = cegui-0.7>=0.7.5: Design custom graphical interfaces
+ optdepends = ffmpeg>=0.8.3: Playback movies on textured surfaces
+ optdepends = gdal: Digital elevation terrains support
+ optdepends = libdart>=3.0: DART support
+ optdepends = libusb: USB peripherals support
+ optdepends = ruby-ronn: Generate manpages
+ optdepends = simbody>=3.3: Simbody support
+ optdepends = urdfdom: Load URDF files
+ provides = gazebo
+ conflicts = gazebo
+ source = gazebo::hg+https://bitbucket.org/osrf/gazebo#branch=default
+ md5sums = SKIP
+
+pkgname = gazebo-hg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1c9331c519e2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,68 @@
+# Contributor: Aris Synodinos <arissynod-gmail-com>
+pkgname=gazebo-hg
+pkgver=6.0.0.19165
+pkgrel=1
+pkgdesc="A multi-robot simulator for outdoor environments. Mercurial version."
+arch=('i686' 'x86_64')
+url="http://gazebosim.org/"
+license=('Apache')
+# See: http://www.gazebosim.org/user_guide/installation__requirements.html
+depends=('boost>=1.40.0' 'curl>=4.0' 'freeglut' 'freeimage>=3.0'
+ 'intel-tbb>=3.0' 'libccd>=1.4' 'libltdl>=2.4.2' 'libtar>=1.2' 'libxml2>=2.7.7'
+ 'ogre' 'protobuf>=2.3.0' 'qt4' 'sdformat>=2.0.1'
+ 'tinyxml>=2.6.2')
+optdepends=('bullet>=2.82: Bullet support'
+ 'cegui-0.7>=0.7.5: Design custom graphical interfaces'
+ 'ffmpeg>=0.8.3: Playback movies on textured surfaces'
+ 'gdal: Digital elevation terrains support'
+ 'libdart>=3.0: DART support'
+ 'libusb: USB peripherals support'
+ 'ruby-ronn: Generate manpages'
+ 'simbody>=3.3: Simbody support'
+ 'urdfdom: Load URDF files')
+makedepends=('cmake' 'doxygen' 'mercurial' 'pkg-config>=0.26')
+install="gazebo.install"
+provides=('gazebo')
+conflicts=('gazebo')
+
+_hgrepo=gazebo
+_hgroot=https://bitbucket.org/osrf
+_dir=${_hgrepo}
+
+source=("${_hgrepo}"::"hg+${_hgroot}/${_hgrepo}"#branch=default)
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_dir}"
+
+ local gazebo_major="$(sed -n 's/set (GAZEBO_MAJOR_VERSION \([0-9]\+\))/\1/p' CMakeLists.txt)"
+ local gazebo_minor="$(sed -n 's/set (GAZEBO_MINOR_VERSION \([0-9]\+\))/\1/p' CMakeLists.txt)"
+ local gazebo_patch="$(sed -n 's/set (GAZEBO_PATCH_VERSION \([0-9]\+\))/\1/p' CMakeLists.txt)"
+ printf "%s.%s" "${gazebo_major}.${gazebo_minor}.${gazebo_patch}" "$(hg identify -n)"
+}
+
+build() {
+ cd "${srcdir}/${_dir}"
+
+ # Create build directory
+ mkdir -p build && cd build
+
+ # Run CMake
+ # Note: we skip unit tests (else set to TRUE)
+ cmake .. -DCMAKE_BUILD_TYPE="Release" \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DCMAKE_INSTALL_LIBDIR="lib" \
+ -DENABLE_TESTS_COMPILATION:BOOL=False
+
+ # Compile Gazebo
+ make
+}
+
+package() {
+ cd "${srcdir}/${_dir}/build"
+
+ # Install Gazebo
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/gazebo.install b/gazebo.install
new file mode 100644
index 000000000000..19479994c944
--- /dev/null
+++ b/gazebo.install
@@ -0,0 +1,6 @@
+post_install() {
+ echo "==> Now you need to export some Gazebo variables:"
+ echo "==> If you're using bash:"
+ echo "==> echo 'source /usr/share/gazebo/setup.sh' >> ~/.bashrc"
+ echo "==> source ~/.bashrc"
+}