summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Martí2016-02-23 17:02:54 +0000
committerDaniel Martí2016-02-23 17:03:32 +0000
commit34ce94e70f3fd0ebaafccc2b9c1a24a1a88bdf36 (patch)
tree684af6231985c478e0548514f2926c9c0c8cb5ed
downloadaur-34ce94e70f3fd0ebaafccc2b9c1a24a1a88bdf36.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD39
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c83adac4029f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Tue Feb 23 17:02:41 UTC 2016
+pkgbase = gb
+ pkgdesc = The project based build tool for Go
+ pkgver = v0.4.0
+ pkgrel = 1
+ url = https://github.com/constabulary/gb
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = go
+ options = !strip
+ source = gb::git+https://github.com/constabulary/gb
+ sha256sums = SKIP
+
+pkgname = gb
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..339f66065fca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Daniel Martí <mvdan@mvdan.cc>
+
+pkgname=gb
+pkgver=v0.4.0
+pkgrel=1
+pkgdesc="The project based build tool for Go"
+url="https://github.com/constabulary/${pkgname}"
+license=('MIT')
+arch=('i686' 'x86_64')
+conflicts=()
+provides=()
+makedepends=('git' 'go')
+options=('!strip')
+source=("${pkgname}::git+${url}")
+sha256sums=('SKIP')
+_cmds="gb gb-vendor"
+
+prepare() {
+ cd "${srcdir}"
+ mkdir -p "src/github.com/constabulary"
+ mv "${pkgname}" "src/github.com/constabulary/${pkgname}"
+}
+
+build() {
+ cd "${srcdir}/src/github.com/constabulary/${pkgname}"
+ for cmd in ${_cmds}; do
+ pushd "cmd/${cmd}"
+ GOPATH="${srcdir}" go build
+ popd
+ done
+}
+
+package() {
+ cd "${srcdir}/src/github.com/constabulary/${pkgname}"
+ for cmd in ${_cmds}; do
+ install -Dm755 "cmd/${cmd}/${cmd}" "${pkgdir}/usr/bin/${cmd}"
+ done
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}