summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmitri Goutnik2018-01-27 16:18:32 -0500
committerDmitri Goutnik2018-01-27 16:22:48 -0500
commit94bd458edd7dd3dbca4a90226609537e414c59b4 (patch)
tree6f59bc6b21a06ad865c237fc181e7dd43bdea3a0
parent47ac4bdb8cefad0eb18a8bda29e26979168293d5 (diff)
downloadaur-94bd458edd7dd3dbca4a90226609537e414c59b4.tar.gz
Adopt, update to gb 0.4.4-1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD48
2 files changed, 27 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7380b6bcc7c7..fe472abef9b4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Mon Jul 4 12:28:17 UTC 2016
pkgbase = gb
pkgdesc = The project based build tool for Go
- pkgver = 0.4.3
+ pkgver = 0.4.4
pkgrel = 1
url = https://github.com/constabulary/gb
arch = i686
@@ -10,9 +8,9 @@ pkgbase = gb
license = MIT
makedepends = git
makedepends = go
- options = !strip
- source = gb::git+https://github.com/constabulary/gb
- sha256sums = SKIP
+ depends = glibc
+ source = gb-0.4.4.tar.gz::https://github.com/constabulary/gb/archive/v0.4.4.tar.gz
+ sha256sums = c7993ae1994ad85cbe35b833d36a137772599fe7ed720edec2d76ebf3fc4313b
pkgname = gb
diff --git a/PKGBUILD b/PKGBUILD
index 72d68d528b18..82d12208cb29 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,38 @@
-# Maintainer: Daniel Martí <mvdan@mvdan.cc>
+# Maintainer: Dmitri Goutnik <dg@syrec.org>
+# Contributor: Daniel Martí <mvdan@mvdan.cc>
pkgname=gb
-pkgver=0.4.3
+pkgver=0.4.4
pkgrel=1
pkgdesc="The project based build tool for Go"
-url="https://github.com/constabulary/${pkgname}"
-license=('MIT')
arch=('i686' 'x86_64')
-conflicts=()
-provides=()
+url="https://github.com/constabulary/gb"
+license=('MIT')
+depends=('glibc')
makedepends=('git' 'go')
-options=('!strip')
-source=("${pkgname}::git+${url}")
-sha256sums=('SKIP')
-_cmds="gb gb-vendor"
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('c7993ae1994ad85cbe35b833d36a137772599fe7ed720edec2d76ebf3fc4313b')
prepare() {
- cd "${srcdir}"
- mkdir -p "src/github.com/constabulary"
- GOPATH="$PWD" go get -d github.com/pkg/errors
- mv "${pkgname}" "src/github.com/constabulary/${pkgname}"
+ mkdir -p src/github.com/constabulary
+ mv ${pkgname}-${pkgver} src/github.com/constabulary/gb
+ env GOPATH="${srcdir}" go get -d github.com/pkg/errors
}
build() {
- cd "${srcdir}/src/github.com/constabulary/${pkgname}"
- for cmd in ${_cmds}; do
- pushd "cmd/${cmd}"
- GOPATH="${srcdir}" go build
- popd
- done
+ cd src/github.com/constabulary/gb
+ for c in gb gb-vendor; do
+ env GOPATH="${srcdir}" go build ./cmd/${c}
+ done
}
+# check() {
+# cd src/github.com/constabulary/gb
+# env GOPATH="${srcdir}" ./gb test
+# }
+
package() {
- cd "${srcdir}/src/github.com/constabulary/${pkgname}"
- for cmd in ${_cmds}; do
- install -Dm755 "cmd/${cmd}/${cmd}" "${pkgdir}/usr/bin/${cmd}"
- done
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cd src/github.com/constabulary/gb
+ install -Dm755 -t "${pkgdir}/usr/bin" gb gb-vendor
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}