summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp Joram2015-09-07 14:34:48 +0200
committerPhilipp Joram2015-09-07 14:34:48 +0200
commiteb1091ed85fb7dfd38a50de1605759f4216a0c18 (patch)
treef3299add8b39b564a96c2cbe9698a4949fd435b9
downloadaur-eb1091ed85fb7dfd38a50de1605759f4216a0c18.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD31
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0f9097011c25
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = gba-pkm-save-edit-git
+ pkgdesc = A commandline application to edit save files of Pokémon-games for the GBA
+ pkgver = 0.r168.5ba5342
+ pkgrel = 1
+ url = https://github.com/phijor/gba-pkm-save-edit
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = make
+ depends = glibc
+ source = gba-pkm-save-edit-git::git+https://github.com/phijor/gba-pkm-save-edit.git
+ md5sums = SKIP
+
+pkgname = gba-pkm-save-edit-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d48c7f5877dd
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*/
+*.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..22af376f9f00
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Philipp Joram <phijor AT t-online DOT de>
+
+_gitname=gba-pkm-save-edit
+pkgname=${_gitname}-git
+pkgver=0.r168.5ba5342
+pkgrel=1
+pkgdesc="A commandline application to edit save files of Pokémon-games for the GBA"
+arch=('x86_64')
+url="https://github.com/phijor/gba-pkm-save-edit"
+license=('GPL3')
+depends=('glibc')
+makedepends=('git' 'make')
+source=("${pkgname}::git+https://github.com/phijor/gba-pkm-save-edit.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ printf "0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname}"
+ install -Dm 0755 ${_gitname} "${pkgdir}/usr/bin/${_gitname}"
+}
+
+# vim:set ts=2 sw=2 et: