summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Jones2019-02-16 20:23:30 +0000
committerPhilip Jones2019-02-16 20:25:19 +0000
commit3929524e9f45b2d0562e46fd24309a267452f009 (patch)
tree271352d8e63995dcae71c97704551085f3887efe
parent939c8ed82e8418cb1f1531f66df268ea15d0dd56 (diff)
downloadaur-3929524e9f45b2d0562e46fd24309a267452f009.tar.gz
Switching to meson/ninja.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD25
2 files changed, 15 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e4724cbb288a..5b73b9b140df 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gbcc-git
pkgdesc = A Game Boy Color emulator written in C
- pkgver = r174.0b4b105
+ pkgver = r178.9cd81ef
pkgrel = 1
url = https://github.com/philj56/GBCC
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 7d6a6231f7c5..fbce4f6af4c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Philip Jones <philj56@gmail.com>
-pkgname='gbcc-git'
-pkgver=r174.0b4b105
+pkgname=gbcc-git
+pkgver=r178.9cd81ef
pkgrel=1
pkgdesc="A Game Boy Color emulator written in C"
-arch=('x86_64')
+arch=("x86_64")
url="https://github.com/philj56/GBCC"
-license=('GPL')
+license=("MIT")
groups=()
-depends=('sdl2' 'libpng')
-makedepends=('git')
+depends=("sdl2" "libpng")
+makedepends=("meson" "git" "scdoc")
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
replaces=()
@@ -17,21 +17,24 @@ options=()
install=
source=("${pkgname}::git+${url}")
noextract=()
-sha512sums=('SKIP')
+sha512sums=("SKIP")
pkgver() {
cd "${pkgname}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd "${pkgname}"
+ meson --prefix /usr build
+}
+
build() {
cd "${pkgname}"
- make clean
- make
+ ninja -C build
}
package() {
cd "${pkgname}"
- install -Dm755 gbcc "${pkgdir}/usr/bin/gbcc"
- install -Dm644 tileset.png "${pkgdir}/usr/share/games/gbcc/tileset.png"
+ DESTDIR="$pkgdir/" ninja -C build install
}