summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpzl2022-06-30 10:56:58 -0400
committerpzl2022-06-30 10:56:58 -0400
commitd683b7f3d02114995c9ea2fcf6c76e033a058efe (patch)
tree9108385fbb73c2e15aff2c4fc24e858a9ebd68ab
parentd89c6752a6280356685c0b569e68b7623f33c35b (diff)
downloadaur-d683b7f3d02114995c9ea2fcf6c76e033a058efe.tar.gz
add printf patch
-rw-r--r--PKGBUILD7
-rw-r--r--format-security.patch36
2 files changed, 41 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4652fc9e7f15..1e8af9133843 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,16 +12,19 @@ depends=(gtk2)
source=(http://sofia.nmsu.edu/~mleisher/Software/gbdfed/$pkgname-$pkgver.tar.bz2 \
http://sofia.nmsu.edu/~mleisher/Software/gbdfed/gbdfed48x48.png \
gbdfed.desktop \
- num_signals.patch)
+ num_signals.patch\
+ format-security.patch)
md5sums=('2a2e1cbfe8566db6d302f0b9ab79b8dd'
'3681abf22f23a62c48acfca417655dd0'
'9e4dd5cb12245e7ea51f53085a714360'
- '0034b837f9217ebdf5a271d2e242d635')
+ '0034b837f9217ebdf5a271d2e242d635'
+ '2188364eb5d5eb694d86d28236de9db7')
build() {
cd $srcdir/$pkgname-$pkgver
sed -i 's/-D.*_DEPRECATED\s*\\*//' Makefile.in
patch -p1 < ../num_signals.patch
+ patch -p1 < ../format-security.patch
./configure --prefix=/usr
make
}
diff --git a/format-security.patch b/format-security.patch
new file mode 100644
index 000000000000..3679d7de75b3
--- /dev/null
+++ b/format-security.patch
@@ -0,0 +1,36 @@
+--- a/bdf.c
++++ b/bdf.c
+@@ -2843,14 +2843,14 @@
+ bpr = ((c->bbx.width * font->bpp) + 7) >> 3;
+ for (j = 0; bpr != 0 && j < c->bytes; j++) {
+ if (j && j % bpr == 0)
+- fprintf(out, eol);
++ fprintf(out, "%s", eol);
+ fprintf(out, "%02X", c->bitmap[j]);
+ }
+ /*
+ * Handle empty bitmaps like this.
+ */
+ if (c->bbx.height > 0)
+- fprintf(out, eol);
++ fprintf(out, "%s", eol);
+ fprintf(out, "ENDCHAR%s", eol);
+
+ /*
+@@ -2915,14 +2915,14 @@
+ bpr = ((c->bbx.width * font->bpp) + 7) >> 3;
+ for (j = 0; bpr != 0 && j < c->bytes; j++) {
+ if (j && j % bpr == 0)
+- fprintf(out, eol);
++ fprintf(out, "%s", eol);
+ fprintf(out, "%02X", c->bitmap[j]);
+ }
+ /*
+ * Handle empty bitmaps like this.
+ */
+ if (c->bbx.height > 0)
+- fprintf(out, eol);
++ fprintf(out, "%s", eol);
+ fprintf(out, "ENDCHAR%s", eol);
+
+ /*