summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Riedel2021-02-14 22:09:30 +0100
committerSebastian Riedel2021-02-14 22:09:30 +0100
commit271a12724900d9d6bcf98e6b37216e096ff8f192 (patch)
tree87e2f5d7afa1495f21e16f8f56a9d29039f8afe3
parent0e32075cb381f152a900073690140c4226662bf6 (diff)
downloadaur-271a12724900d9d6bcf98e6b37216e096ff8f192.tar.gz
Update to version 4.0.2
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD30
2 files changed, 23 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 25dd2d906635..f41f77b62c86 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = gbdk-2020
pkgdesc = An updated version of Game Boy Development Kit
- pkgver = 3.2
- pkgrel = 4
+ pkgver = 4.0.2
+ pkgrel = 1
url = https://github.com/Zal0/gbdk-2020
arch = x86_64
arch = i686
license = MIT
- makedepends = sdcc
- makedepends = svn
- depends = sdcc
+ makedepends = sdcc>=4.0.7.svn12016M
+ makedepends = git
+ depends = sdcc>=4.0.7.svn12016M
conflicts = gbdk
conflicts = lcc
- source = git+https://github.com/basxto/gbdk-2020#commit=87969af9aae690f85439460e73131273af3c8f4a
+ options = !strip
+ source = git+https://github.com/basxto/gbdk-2020#commit=c2edd502370ea39893f02e9fa58a772f0488071f
sha256sums = SKIP
pkgname = gbdk-2020
diff --git a/PKGBUILD b/PKGBUILD
index eccbe6cb2739..8248ff5958e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,27 +2,29 @@
# based on gbdk package
pkgname=gbdk-2020
-pkgver=3.2
-pkgrel=4
+pkgver=4.0.2
+pkgrel=1
pkgdesc="An updated version of Game Boy Development Kit"
url="https://github.com/Zal0/gbdk-2020"
license=('MIT')
arch=('x86_64' 'i686')
-makedepends=('sdcc' 'svn')
-depends=('sdcc')
+makedepends=('sdcc>=4.0.7.svn12016M' 'git')
+depends=('sdcc>=4.0.7.svn12016M')
conflicts=('gbdk' 'lcc')
-# this is branch lcc-patch
-source=("git+https://github.com/basxto/gbdk-2020#commit=87969af9aae690f85439460e73131273af3c8f4a")
-#should be merged in the next version
-#source=("https://github.com/Zal0/gbdk-2020/archive/v${pkgver}.tar.gz")
+# this is branch 4.0.2-patched
+source=("git+https://github.com/basxto/gbdk-2020#commit=c2edd502370ea39893f02e9fa58a772f0488071f")
+# should be merged in the next version
+#source=("https://github.com/Zal0/gbdk-2020/archive/${pkgver}.tar.gz")
sha256sums=('SKIP')
+options=('!strip')
package() {
- make -C ${pkgname} gbdk-build gbdk-support-install gbdk-lib-install TARGETDIR=/opt/${pkgname} BINDIR=/usr/bin/ SDCCDIR=/usr/
- mkdir -p ${pkgdir}/usr
- mkdir -p ${pkgdir}/opt
+ make -C ${pkgname} gbdk-build gbdk-support-install gbdk-lib-install TARGETDIR=/usr/share/${pkgname}/ BINDIR=/usr/bin/ SDCCDIR=/usr/
+ mkdir -p ${pkgdir}/usr/share/licenses/${pkgname}/
- mv ${pkgname}/build/gbdk ${pkgdir}/opt/${pkgname}
- mv ${pkgdir}/opt/${pkgname}/bin ${pkgdir}/usr/
- find ${pkgdir}/opt/${pkgname}/ -type f -name '*.bat' -delete
+ mv ${pkgname}/build/gbdk ${pkgdir}/usr/share/${pkgname}
+ mv ${pkgdir}/usr/share/${pkgname}/bin ${pkgdir}/usr/
+ find ${pkgdir}/usr/share/${pkgname}/ -type f -name '*.bat' -delete
+ rm -rf ${pkgdir}/usr/share/${pkgname}/examples/
+ cp ${pkgname}/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/
}