summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Riedel2021-03-26 22:31:32 +0100
committerSebastian Riedel2021-03-26 22:31:32 +0100
commit81b8be9cf5fac9f06353f9aa9e5616e2c0fa8c82 (patch)
tree1c418aadb415d66cf7a7d4e2afe3e9175a85bca0
parentd48659b43cab97a3fa48fa08731bfa937d7d624f (diff)
downloadaur-81b8be9cf5fac9f06353f9aa9e5616e2c0fa8c82.tar.gz
Update to version 4.0.3
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD23
2 files changed, 16 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 69574778d8cf..db863b3e4772 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
pkgbase = gbdk-2020
pkgdesc = An updated version of Game Boy Development Kit
- pkgver = 4.0.2
- pkgrel = 2
+ pkgver = 4.0.3
+ pkgrel = 1
url = https://github.com/Zal0/gbdk-2020
arch = x86_64
arch = i686
license = MIT
makedepends = git
- makedepends = sdcc>=4.0.7.svn12016M
- depends = sdcc>=4.0.7.svn12016M
+ makedepends = sdcc>=4.1.0
+ depends = sdcc>=4.1.0
conflicts = gbdk
conflicts = lcc
options = !strip
- source = git+https://github.com/Zal0/gbdk-2020#commit=c2edd502370ea39893f02e9fa58a772f0488071f
- sha256sums = SKIP
+ source = https://github.com/Zal0/gbdk-2020/archive/4.0.3.tar.gz
+ sha256sums = 53d90bfa5ec63e1c39ceedb653acaed92309e8b5d34a2d1239717947f469e75f
pkgname = gbdk-2020
diff --git a/PKGBUILD b/PKGBUILD
index e989e4409099..c4677e9b0320 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,29 +2,26 @@
# based on gbdk package
pkgname=gbdk-2020
-pkgver=4.0.2
-pkgrel=2
+pkgver=4.0.3
+pkgrel=1
pkgdesc="An updated version of Game Boy Development Kit"
url="https://github.com/Zal0/gbdk-2020"
license=('MIT')
arch=('x86_64' 'i686')
-makedepends=('git' 'sdcc>=4.0.7.svn12016M')
-depends=('sdcc>=4.0.7.svn12016M')
+makedepends=('git' 'sdcc>=4.1.0')
+depends=('sdcc>=4.1.0')
conflicts=('gbdk' 'lcc')
-# those are merged patches for 4.0.2 (not exactly release 4.0.2)
-source=("git+https://github.com/Zal0/gbdk-2020#commit=c2edd502370ea39893f02e9fa58a772f0488071f")
-# should be merged in the next version
-#source=("https://github.com/Zal0/gbdk-2020/archive/${pkgver}.tar.gz")
-sha256sums=('SKIP')
+source=("https://github.com/Zal0/gbdk-2020/archive/${pkgver}.tar.gz")
+sha256sums=('53d90bfa5ec63e1c39ceedb653acaed92309e8b5d34a2d1239717947f469e75f')
options=('!strip')
package() {
- make -C ${pkgname} gbdk-build gbdk-support-install gbdk-lib-install TARGETDIR=/usr/share/${pkgname}/ BINDIR=/usr/bin/ SDCCDIR=/usr/
+ make -C ${pkgname}-${pkgver} gbdk-build gbdk-support-install gbdk-lib-install TARGETDIR=/usr/share/${pkgname}/ BINDIR=/usr/bin/ SDCCDIR=/usr/
mkdir -p ${pkgdir}/usr/share/licenses/${pkgname}/
- mv ${pkgname}/build/gbdk ${pkgdir}/usr/share/${pkgname}
+ mv ${pkgname}-${pkgver}/build/gbdk ${pkgdir}/usr/share/${pkgname}
mv ${pkgdir}/usr/share/${pkgname}/bin ${pkgdir}/usr/
- find ${pkgdir}/usr/share/${pkgname}/ -type f -name '*.bat' -delete
+ find ${pkgdir}/usr/share/${pkgname}/ -type f -name '*.bat' -delete -o -type f -name '*.dox' -delete
rm -rf ${pkgdir}/usr/share/${pkgname}/examples/
- cp ${pkgname}/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/
+ cp ${pkgname}-${pkgver}/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/
}