summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNate Hart2015-06-08 12:53:20 -0500
committerNate Hart2015-06-08 12:53:20 -0500
commit5036144211b77c31b899508c1f6fa046dca7c251 (patch)
tree5b4fd8f872e786f0e4bdfbd5bcd0a809d46834eb
downloadaur-5036144211b77c31b899508c1f6fa046dca7c251.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD22
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5d6e2faf2f37
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = gcalert
+ pkgdesc = Lightweight Google Calendar notifications
+ pkgver = 3.2
+ pkgrel = 5
+ url = https://github.com/nejsan/gcalert
+ arch = any
+ license = GPL
+ depends = python
+ depends = libnotify
+ depends = python-google-api-python-client
+ depends = python-notify2
+ depends = python-dateutil
+ source = gcalert-3.2::https://raw.githubusercontent.com/nejsan/gcalert/v3.2/gcalert
+ sha256sums = 81ea48b99cbe0baa40295114ecf7c5c6a7acc4eeb774cc28ae4579f5bb70dd02
+
+pkgname = gcalert
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0aff6cce12c9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Nate Hart <nejthan@gmail.com>
+
+pkgname=gcalert
+pkgver=3.2
+pkgrel=5
+pkgdesc='Lightweight Google Calendar notifications'
+arch=('any')
+url=https://github.com/nejsan/gcalert
+license=('GPL')
+depends=('python' 'libnotify' 'python-google-api-python-client' 'python-notify2' 'python-dateutil')
+source=("$pkgname-$pkgver::https://raw.githubusercontent.com/nejsan/gcalert/v$pkgver/gcalert")
+sha256sums=('81ea48b99cbe0baa40295114ecf7c5c6a7acc4eeb774cc28ae4579f5bb70dd02')
+
+prepare() {
+ sed -i -e "1s/3$//" gcalert-$pkgver
+}
+
+package() {
+ install -Dm755 gcalert-$pkgver "$pkgdir"/usr/bin/gcalert
+}
+
+# vim:set ts=2 sw=2 et: