summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVadzim Dambrouski2015-11-03 18:25:20 +0300
committerVadzim Dambrouski2015-11-03 18:25:20 +0300
commitfa85902357e1edd40fbeab09ff539d63b0234adb (patch)
tree2599fb2f5a07c9ae9ab4bb19c836b32236db90b1
parentd820751cc008bb56522b8f140af12c79a30db0f1 (diff)
downloadaur-fa85902357e1edd40fbeab09ff539d63b0234adb.tar.gz
updated to q3 (20150921), removed GDB and ncurses dependency
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD27
2 files changed, 21 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 049b6d3855f9..b0480127f91d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,25 @@
pkgbase = gcc-arm-none-eabi-bin
- pkgdesc = GNU Tools ARM Embedded Processors (binary distribution, includes GDB and newlib)
- pkgver = 4.9_2015_q2_update
+ pkgdesc = GNU Tools ARM Embedded Processors (binary distribution, includes newlib, does NOT include GDB)
+ pkgver = 4.9_2015_q3_update
pkgrel = 1
url = https://launchpad.net/gcc-arm-embedded
arch = i686
arch = x86_64
license = custom
- depends = ncurses
depends = glibc
+ optdepends = arm-none-eabi-gdb: GNU Debugger for ARM EABI
provides = gcc-arm-none-eabi
provides = arm-none-eabi-gcc
- provides = arm-none-eabi-gdb
provides = arm-none-eabi-binutils
provides = arm-none-eabi-newlib
conflicts = gcc-arm-none-eabi
conflicts = arm-none-eabi-gcc
- conflicts = arm-none-eabi-gdb
conflicts = arm-none-eabi-binutils
conflicts = arm-none-eabi-newlib
options = !strip
options = staticlibs
- source = https://launchpad.net/gcc-arm-embedded/4.9/4.9-2015-q2-update/+download/gcc-arm-none-eabi-4_9-2015q2-20150609-linux.tar.bz2
- md5sums = 3a574c5becfca496bafe07bbd76e9deae1fd0cc99c5a9de0f8c610750f2f89ac
+ source = https://launchpad.net/gcc-arm-embedded/4.9/4.9-2015-q3-update/+download/gcc-arm-none-eabi-4_9-2015q3-20150921-linux.tar.bz2
+ sha256sums = c50078bfbd29e6c15615900e746f4d0acde917338e55860b0f145f57387c12ab
pkgname = gcc-arm-none-eabi-bin
diff --git a/PKGBUILD b/PKGBUILD
index 43c943aa9278..865047c85e07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,31 @@
# Original Maintainer: James Duley <jagduley gmail>
+# Previous Maintainer: 2bluesc <2bluesc gmail.com>
+# Maintainer: Vadzim Dambrouski <pftbest gmail.com>
pkgname=gcc-arm-none-eabi-bin
-pkgver=4.9_2015_q2_update
+pkgver=4.9_2015_q3_update
_pkgname=gcc-arm-none-eabi
_pkgver=${pkgver//_/-}
_pkgvershort=${_pkgver%-*}
_pkgvershort=${_pkgvershort/-q/q}
-_pkgdate=20150609
+_pkgdate=20150921
pkgrel=1
-pkgdesc="GNU Tools ARM Embedded Processors (binary distribution, includes GDB and newlib)"
+pkgdesc="GNU Tools ARM Embedded Processors (binary distribution, includes newlib, does NOT include GDB)"
arch=('i686' 'x86_64')
if [ "${CARCH}" = "x86_64" ]; then
- depends=('lib32-ncurses' 'lib32-glibc')
+ depends=('lib32-glibc')
else
- depends=('ncurses' 'glibc')
+ depends=('glibc')
fi
+optdepends=(
+ 'arm-none-eabi-gdb: GNU Debugger for ARM EABI'
+ )
provides=('gcc-arm-none-eabi'
'arm-none-eabi-gcc'
- 'arm-none-eabi-gdb'
'arm-none-eabi-binutils'
'arm-none-eabi-newlib'
)
conflicts=('gcc-arm-none-eabi'
'arm-none-eabi-gcc'
- 'arm-none-eabi-gdb'
'arm-none-eabi-binutils'
'arm-none-eabi-newlib'
)
@@ -30,10 +33,12 @@ url="https://launchpad.net/gcc-arm-embedded"
source="https://launchpad.net/gcc-arm-embedded/${pkgver%%_*}/${_pkgver}/+download/${_pkgname}-${_pkgvershort/./_}-${_pkgdate}-linux.tar.bz2"
license=('custom')
options=(!strip staticlibs)
-sha256sums=('3a574c5becfca496bafe07bbd76e9deae1fd0cc99c5a9de0f8c610750f2f89ac')
+sha256sums=('c50078bfbd29e6c15615900e746f4d0acde917338e55860b0f145f57387c12ab')
package() {
- mkdir -p $pkgdir/usr
- cd $srcdir/gcc-*
- cp -a * $pkgdir/usr
+ mkdir -p $pkgdir/usr
+ cd $srcdir/gcc-*
+ cp -a * $pkgdir/usr
+ rm -f $pkgdir/usr/bin/arm-none-eabi-gdb
+ rm -f $pkgdir/usr/bin/arm-none-eabi-gdb-py
}