summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoão Figueiredo2021-08-26 23:14:54 +0100
committerJoão Figueiredo2021-08-26 23:14:54 +0100
commit3bcb9bfb310005d3e9556f114112e8312fae29f3 (patch)
treeb3a5ab9393e8c82c0c4231d43c5464097ed4f14b
parentce77228611110bb47e3941fe93dd66db6cfa2476 (diff)
downloadaur-3bcb9bfb310005d3e9556f114112e8312fae29f3.tar.gz
Remove problematic flag (thanks @DAC324!)
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD9
2 files changed, 13 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c17a4d335162..8be13dd2c5f4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gcc-git
pkgdesc = The GNU Compiler Collection
- pkgver = 12.0.0_r187467.ga5416bf3694
+ pkgver = 12.0.0_r187580.g5a6c626710a
pkgrel = 1
url = https://gcc.gnu.org
arch = x86_64
@@ -45,7 +45,7 @@ pkgbase = gcc-git
pkgname = gcc-git
pkgdesc = The GNU Compiler Collection - C and C++ frontends
groups = base-devel-git
- depends = gcc-libs-git=12.0.0_r187467.ga5416bf3694-1
+ depends = gcc-libs-git=12.0.0_r187580.g5a6c626710a-1
depends = binutils>=2.28
depends = libmpc
optdepends = lib32-gcc-libs-git: for generating code for 32-bit ABI
@@ -77,7 +77,7 @@ pkgname = gcc-libs-git
pkgname = gcc-fortran-git
pkgdesc = Fortran front-end for GCC
- depends = gcc-git=12.0.0_r187467.ga5416bf3694-1
+ depends = gcc-git=12.0.0_r187580.g5a6c626710a-1
provides = gcc-fortran
provides = gcc-git-multilib
provides = gcc-git-multilib-git
@@ -86,7 +86,7 @@ pkgname = gcc-fortran-git
pkgname = gcc-objc-git
pkgdesc = Objective-C front-end for GCC
- depends = gcc-git=12.0.0_r187467.ga5416bf3694-1
+ depends = gcc-git=12.0.0_r187580.g5a6c626710a-1
provides = gcc-git-multilib
provides = gcc-git-multilib-git
conflicts = gcc-objc
@@ -94,7 +94,7 @@ pkgname = gcc-objc-git
pkgname = gcc-ada-git
pkgdesc = Ada front-end for GCC (GNAT)
- depends = gcc-git=12.0.0_r187467.ga5416bf3694-1
+ depends = gcc-git=12.0.0_r187580.g5a6c626710a-1
provides = gcc-ada
provides = gcc-git-multilib
provides = gcc-git-multilib-git
@@ -105,7 +105,7 @@ pkgname = gcc-ada-git
pkgname = gcc-go-git
pkgdesc = Go front-end for GCC
- depends = gcc-git=12.0.0_r187467.ga5416bf3694-1
+ depends = gcc-git=12.0.0_r187580.g5a6c626710a-1
provides = go=1.12.2
provides = gcc-git-multilib
provides = gcc-git-multilib-git
@@ -116,7 +116,7 @@ pkgname = gcc-go-git
pkgname = gcc-d-git
pkgdesc = D frontend for GCC
- depends = gcc-git=12.0.0_r187467.ga5416bf3694-1
+ depends = gcc-git=12.0.0_r187580.g5a6c626710a-1
provides = gcc-d
provides = gdc
provides = gdc-git
diff --git a/PKGBUILD b/PKGBUILD
index 3c5dcd16cc19..d170842db7b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
pkgbase=gcc-git
pkgname=(gcc-git gcc-libs-git gcc-fortran-git gcc-objc-git gcc-ada-git gcc-go-git gcc-d-git)
-pkgver=12.0.0_r187467.ga5416bf3694
+pkgver=12.0.0_r187580.g5a6c626710a
_majorver=${pkgver%%.*}
_isl=$(curl -s "http://isl.gforge.inria.fr/?C=M;O=A" | grep tar.xz | tail -1 | sed -e 's/.*href="//' -e 's/">isl.*//')
pkgrel=1
@@ -78,8 +78,11 @@ build() {
# using -pipe causes spurious test-suite failures
# http://gcc.gnu.org/bugzilla/show_bug.cgi?id=48565
- CFLAGS=${CFLAGS/-pipe/}
- CXXFLAGS=${CXXFLAGS/-pipe/}
+ CFLAGS=${CFLAGS/-pipe}
+ CXXFLAGS=${CXXFLAGS/-pipe}
+
+ # See https://aur.archlinux.org/pkgbase/gcc-git/#comment-822240
+ CXXFLAGS=${CXXFLAGS/-Werror=format-security}
"$srcdir/gcc/configure" --prefix=/usr \
--libdir=/usr/lib \