summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoão Figueiredo2021-10-14 00:38:02 +0100
committerJoão Figueiredo2021-10-14 00:38:02 +0100
commite5a742440b8c69eb24b33623b0cdd5beed0593ec (patch)
treeb68027379fb2689bf2507b44068811a40852c7bd
parentcbd092b5a48efacabc652421feeff3b3e0d42428 (diff)
downloadaur-e5a742440b8c69eb24b33623b0cdd5beed0593ec.tar.gz
E n h a n c e ! (aka hacky stuffs + new isl link)
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD41
2 files changed, 35 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be7b1bcf29ad..4a04aec5b905 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gcc-git
pkgdesc = The GNU Compiler Collection
- pkgver = 12.0.0_r188038.g31e924c52f4
- pkgrel = 2
+ pkgver = 12.0.0_r188792.gf874a13ca38
+ pkgrel = 1
url = https://gcc.gnu.org
arch = x86_64
license = GPL
@@ -22,7 +22,7 @@ pkgbase = gcc-git
makedepends = libxcrypt
options = !emptydirs
source = git://gcc.gnu.org/git/gcc.git
- source = http://isl.gforge.inria.fr/isl-0.24.tar.xz
+ source = https://mirrors.slackware.com/slackware/slackware64-current/source/l/isl/isl-0.24.tar.xz
source = c89
source = c99
source = gdc_phobos_path.patch
@@ -45,7 +45,7 @@ pkgbase = gcc-git
pkgname = gcc-git
pkgdesc = The GNU Compiler Collection - C and C++ frontends
groups = base-devel-git
- depends = gcc-libs-git=12.0.0_r188038.g31e924c52f4-2
+ depends = gcc-libs-git=12.0.0_r188792.gf874a13ca38-1
depends = binutils>=2.28
depends = libmpc
optdepends = lib32-gcc-libs-git: for generating code for 32-bit ABI
@@ -60,7 +60,7 @@ pkgname = gcc-git
pkgname = gcc-libs-git
pkgdesc = Runtime libraries shipped by GCC
depends = glibc
- provides = gcc-libs=12.0.0_r188038.g31e924c52f4-2
+ provides = gcc-libs=12.0.0_r188792.gf874a13ca38-1
provides = gcc-multilib
provides = gcc-multilib-git
provides = libgo.so
@@ -77,7 +77,7 @@ pkgname = gcc-libs-git
pkgname = gcc-fortran-git
pkgdesc = Fortran front-end for GCC
- depends = gcc-git=12.0.0_r188038.g31e924c52f4-2
+ depends = gcc-git=12.0.0_r188792.gf874a13ca38-1
provides = gcc-fortran
provides = gcc-multilib
provides = gcc-multilib-git
@@ -86,7 +86,7 @@ pkgname = gcc-fortran-git
pkgname = gcc-objc-git
pkgdesc = Objective-C front-end for GCC
- depends = gcc-git=12.0.0_r188038.g31e924c52f4-2
+ depends = gcc-git=12.0.0_r188792.gf874a13ca38-1
provides = gcc-multilib
provides = gcc-multilib-git
conflicts = gcc-objc
@@ -94,7 +94,7 @@ pkgname = gcc-objc-git
pkgname = gcc-ada-git
pkgdesc = Ada front-end for GCC (GNAT)
- depends = gcc-git=12.0.0_r188038.g31e924c52f4-2
+ depends = gcc-git=12.0.0_r188792.gf874a13ca38-1
provides = gcc-ada
provides = gcc-multilib
provides = gcc-multilib-git
@@ -105,7 +105,7 @@ pkgname = gcc-ada-git
pkgname = gcc-go-git
pkgdesc = Go front-end for GCC
- depends = gcc-git=12.0.0_r188038.g31e924c52f4-2
+ depends = gcc-git=12.0.0_r188792.gf874a13ca38-1
provides = go=1.12.2
provides = gcc-multilib
provides = gcc-multilib-git
@@ -116,7 +116,7 @@ pkgname = gcc-go-git
pkgname = gcc-d-git
pkgdesc = D frontend for GCC
- depends = gcc-git=12.0.0_r188038.g31e924c52f4-2
+ depends = gcc-git=12.0.0_r188792.gf874a13ca38-1
provides = gcc-d
provides = gdc
provides = gdc-git
diff --git a/PKGBUILD b/PKGBUILD
index c65cbd25efc5..ce7fc59bdfbd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,15 @@
# NOTE: libtool requires rebuilding with each new gcc version
# You probably don't need support for all the languages, feel free to remove the ones you don't;
-# Just edit the --enable-languages option as well as the pkgname array :)
+# Just edit the --enable-languages option as well as the pkgname array, and comment out the pkg functions :)
pkgbase=gcc-git
pkgname=({gcc,gcc-libs,gcc-fortran,gcc-objc,gcc-ada,gcc-go,gcc-d}-git)
-pkgver=12.0.0_r188038.g31e924c52f4
+pkgver=12.0.0_r188792.gf874a13ca38
_majorver=${pkgver%%.*}
-_isl=$(curl -s "http://isl.gforge.inria.fr/?C=M;O=A" | grep "isl-.*tar\.xz" | tail -1 | sed -e 's/.*href="//' -e 's/">isl.*//')
-pkgrel=2
+_isl_link=https://mirrors.slackware.com/slackware/slackware64-current/source/l/isl
+_isl=$(curl -s "$_isl_link/?C=M;O=A" | grep "isl-.*tar\.xz" | tail -1 | sed -e 's/.*href="//' -e 's/\.mirrorlist.*//')
+pkgrel=1
pkgdesc='The GNU Compiler Collection'
arch=($CARCH)
license=(GPL LGPL FDL custom)
@@ -22,7 +23,7 @@ options=(!emptydirs)
_libdir=usr/lib/gcc/$CHOST/${pkgver%_*}
source=(git://gcc.gnu.org/git/gcc.git
- http://isl.gforge.inria.fr/$_isl
+ $_isl_link/$_isl
c89 c99
gdc_phobos_path.patch
fs64270.patch
@@ -144,33 +145,39 @@ package_gcc-libs-git() {
libubsan.so libasan.so libtsan.so liblsan.so)
replaces=(gcc-multilib-git libgphobos-git)
- cd gcc-build
- make -C $CHOST/libgcc DESTDIR="$pkgdir" install-shared
+ cd gcc-build/$CHOST
+ make -C libgcc DESTDIR="$pkgdir" install-shared
rm -f "$pkgdir/$_libdir/libgcc_eh.a"
+ # beautiful hack I came up with to skip libs when they're missing :)
+ # i.e. when the respective languages were disabled
+ shopt -s nullglob
for lib in libatomic \
- libgfortran \
- libgo \
+ [l]ibgfortran \
+ [l]ibgo \
libgomp \
libitm \
libquadmath \
libsanitizer/{a,l,ub,t}san \
libstdc++-v3/src \
libvtv; do
- make -C $CHOST/$lib DESTDIR="$pkgdir" install-toolexeclibLTLIBRARIES
+ make -C $lib DESTDIR="$pkgdir" install-toolexeclibLTLIBRARIES
done
+ shopt -u nullglob
- make -C $CHOST/libobjc DESTDIR="$pkgdir" install-libs
- make -C $CHOST/libstdc++-v3/po DESTDIR="$pkgdir" install
+ # why ! and || instead of just &&, i hear you ask?
+ # so that $? is always 0 (unless make fails)
+ [[ ! -e libobjc ]] || make -C libobjc DESTDIR="$pkgdir" install-libs
+ make -C libstdc++-v3/po DESTDIR="$pkgdir" install
- make -C $CHOST/libphobos DESTDIR="$pkgdir" install
+ make -C libphobos DESTDIR="$pkgdir" install
rm -rf "$pkgdir"/$_libdir/include/d/
rm -f "$pkgdir"/usr/lib/libgphobos.spec
for lib in libgomp \
libitm \
libquadmath; do
- make -C $CHOST/$lib DESTDIR="$pkgdir" install-info
+ make -C $lib DESTDIR="$pkgdir" install-info
done
# remove files provided by lib32-gcc-libs
@@ -241,8 +248,10 @@ package_gcc-git() {
install -m644 libiberty/pic/libiberty.a "$pkgdir/usr/lib"
make -C gcc DESTDIR="$pkgdir" install-man install-info
- rm "$pkgdir"/usr/share/man/man1/{gccgo,gfortran,gdc}.1
- rm "$pkgdir"/usr/share/info/{gccgo,gfortran,gnat-style,gnat_rm,gnat_ugn,gdc}.info
+
+ # don't fail if can't remove the files (when certain languages were disabled)
+ rm "$pkgdir"/usr/share/man/man1/{gccgo,gfortran,gdc}.1 ||:
+ rm "$pkgdir"/usr/share/info/{gccgo,gfortran,gnat-style,gnat_rm,gnat_ugn,gdc}.info ||:
make -C libcpp DESTDIR="$pkgdir" install
make -C gcc DESTDIR="$pkgdir" install-po