summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Baumann2023-03-09 15:22:44 +0100
committerAndreas Baumann2023-03-09 15:22:44 +0100
commit5ef97bc81eafa1ed60f7e1fc6be957ef52b264d3 (patch)
treef77b6f2f7f7f120515833a710daf00121a314db0
parentce2cd996ffc649b8902ffd4468a822024f4bad21 (diff)
downloadaur-5ef97bc81eafa1ed60f7e1fc6be957ef52b264d3.tar.gz
building less and disabled NLS
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD14
2 files changed, 12 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bf58e2526177..b207738b8240 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gcc-ia16
pkgdesc = IA-16 (Intel 16-bit x86) port of GNU Gcc
pkgver = 20230119
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/tkchia/gcc-ia16
arch = x86_64
license = GPL
diff --git a/PKGBUILD b/PKGBUILD
index 6d9eb476583c..ba25da733721 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Andreas Baumann <mail@andreasbaumann.cc>
pkgname=gcc-ia16
pkgver=20230119
-pkgrel=1
+pkgrel=2
epoch=
pkgdesc="IA-16 (Intel 16-bit x86) port of GNU Gcc"
arch=('x86_64')
@@ -24,15 +24,23 @@ build() {
--bindir=/usr/bin \
--libdir=/usr/lib/ia16-elf/ \
--disable-multilib \
+ --disable-nls \
--without-headers \
--disable-libssp \
--without-isl \
--disable-werror
- make
+ make all-gcc
+ make all-target-libgcc
+}
+
+check() {
+ # currently nope
+ true
}
package() {
cd build-gcc
- make DESTDIR="$pkgdir/" install
+ make DESTDIR="$pkgdir/" install-gcc
+ make DESTDIR="$pkgdir/" install-target-libgcc
rm -rf "$pkgdir/usr/share"
}